plone.rest vulnerable to Denial of Service when ++api++ is used many times
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
plone.rest allows users to use HTTP verbs such as GET, POST, PUT, DELETE, etc. in Plone. Starting in the 2.x branch and prior to versions 2.0.1 and 3.0.1, when the `++api++` traverser is accidentally used multiple times in a url, handling it takes increasingly longer, making the server less responsive. Patches are available in `plone.rest` 2.0.1 and 3.0.1. Series 1.x is not affected. As a workaround, one may redirect `/++api++/++api++` to `/++api++` in one's frontend web server (nginx, Apache).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| plone | plone.rest | 2.0.0a1 to before 2.0.1; = 3.0.0 | 2.0.1 | Patch available | CNA |
| — | plone.rest (PyPI) | 2.0.0a1 to before 2.0.1 | 2.0.1 | Patch available | GHSA-h6rp-mprm-xgcq |
| — | plone.rest (PyPI) | 3.0.0 to before 3.0.1 | 3.0.1 | Patch available | GHSA-h6rp-mprm-xgcq |
- plone.rest Vendorplone Affected 2.0.0a1 to before 2.0.1; = 3.0.0 Fixed in 2.0.1 Patch available CNA
- plone.rest (PyPI) Vendor— Affected 2.0.0a1 to before 2.0.1 Fixed in 2.0.1 Patch available GHSA-h6rp-mprm-xgcq
- plone.rest (PyPI) Vendor— Affected 3.0.0 to before 3.0.1 Fixed in 3.0.1 Patch available GHSA-h6rp-mprm-xgcq
Remediation
- Fix · CNA plone.rest (plone) Fixed in 2.0.1
- Fix · GHSA-h6rp-mprm-xgcq plone.rest (PyPI) Fixed in 2.0.1 Advisory →
- Fix · GHSA-h6rp-mprm-xgcq plone.rest (PyPI) Fixed in 3.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-42457
- 2026-10-03 Alias added: GHSA-h6rp-mprm-xgcq
References
Patch 2
Advisory 3
Sources
- CVE-2023-42457 · CVE Program
- CVE-2023-42457 · NVD
- FIRST EPSS
- GHSA-h6rp-mprm-xgcq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences