Remote code execution on the host system via MongoDB shell in jumpserver
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
JumpServer is an open source bastion host. An authenticated user can exploit a vulnerability in MongoDB sessions to execute arbitrary commands, leading to remote code execution. This vulnerability may further be leveraged to gain root privileges on the system. Through the WEB CLI interface provided by the koko component, a user logs into the authorized mongoDB database and exploits the MongoDB session to execute arbitrary commands. This vulnerability has been addressed in versions 2.28.20 and 3.7.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jumpserver | jumpserver | 2.0.0 to before 2.28.20; 3.0.0 to before 3.7.1 | 2.28.20, 3.7.1 | Patch available | CNA |
| — | github.com/jumpserver/koko (Go) | 2.0.0 to before 2.28.20 | 2.28.20 | Patch available | GHSA-4r5x-x283-wm96 |
| — | github.com/jumpserver/koko (Go) | 3.0.0 to before 3.7.1 | 3.7.1 | Patch available | GHSA-4r5x-x283-wm96 |
- jumpserver Vendorjumpserver Affected 2.0.0 to before 2.28.20; 3.0.0 to before 3.7.1 Fixed in 2.28.20, 3.7.1 Patch available CNA
- github.com/jumpserver/koko (Go) Vendor— Affected 2.0.0 to before 2.28.20 Fixed in 2.28.20 Patch available GHSA-4r5x-x283-wm96
- github.com/jumpserver/koko (Go) Vendor— Affected 3.0.0 to before 3.7.1 Fixed in 3.7.1 Patch available GHSA-4r5x-x283-wm96
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fit2cloud:jumpserver:*:*:*:*:*:*:*:* | 2.0.0 to before 2.28.20; 3.0.0 to before 3.7.1 | Vulnerable | 1Panel-dev |
- cpe:2.3:a:fit2cloud:jumpserver:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.28.20; 3.0.0 to before 3.7.1 Vulnerable ·1Panel-dev
Remediation
- Fix · CNA jumpserver (jumpserver) Fixed in 2.28.20, 3.7.1
- Fix · GHSA-4r5x-x283-wm96 github.com/jumpserver/koko (Go) Fixed in 2.28.20 Advisory →
- Fix · GHSA-4r5x-x283-wm96 github.com/jumpserver/koko (Go) Fixed in 3.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-43651
- 2026-10-03 Alias added: GHSA-4r5x-x283-wm96
References
Other 4
More jumpserver vulnerabilities
- TI-2024-27040 Arbitrary File Read in Ansible Playbooks in Jumpserver CVSS 3.1CRITICAL 10.0
- TI-2023-23378 Non-MFA account takeover via using only SSH public key to login in jumpserver CVSS 3.1CRITICAL 9.1
- TI-2023-22607 JumpServer session replays download without authentication CVSS 3.1HIGH 8.2
- TI-2024-27041 Arbitrary File Write in Ansible Playbooks leads to RCE in Jumpserver CVSS 3.1CRITICAL 10.0
- TI-2024-19371 JumpServer vulnerable to Jinja2 template injection in Ansible leads to RCE in Celery CVSS 3.1CRITICAL 10.0
- TI-2024-19370 JumpServer's insecure Ansible playbook validation leads to RCE in Celery CVSS 3.1CRITICAL 10.0
Sources
- CVE-2023-43651 · CVE Program
- CVE-2023-43651 · NVD
- FIRST EPSS
- GHSA-4r5x-x283-wm96 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences