Hard-coded credentials in Paxton Net2
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-798.
Summary
When installing the Net2 software a root certificate is installed into the trusted store. A potential hacker could access the installer batch file or reverse engineer the source code to gain access to the root certificate password. Using the root certificate and password they could then create their own certificates to emulate another site. Then by establishing a proxy service to emulate the site they could monitor traffic passed between the end user and the site allowing access to the data content.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Paxton | Net2 | 6.02 to before 6.07 SR1 | 6.07 SR1 | Patch available | CNA |
- Net2 VendorPaxton Affected 6.02 to before 6.07 SR1 Fixed in 6.07 SR1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:paxton-access:net2:*:*:*:*:*:*:*:* | 6.02 to before 6.07 | Vulnerable | Paxton-access |
| cpe:2.3:a:paxton-access:net2:6.07:-:*:*:*:*:*:* | 6.07 | Vulnerable | Paxton-access |
- cpe:2.3:a:paxton-access:net2:*:*:*:*:*:*:*:* Versions 6.02 to before 6.07 Vulnerable ·Paxton-access
- cpe:2.3:a:paxton-access:net2:6.07:-:*:*:*:*:*:* Versions 6.07 Vulnerable ·Paxton-access
Remediation
- Fix · CNA Net2 (Paxton) Fixed in 6.07 SR1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-43870
- 2026-10-03 Alias added: GHSA-jq9x-r769-726q
References
Other 1
Sources
- CVE-2023-43870 · CVE Program
- CVE-2023-43870 · NVD
- FIRST EPSS
- GHSA-jq9x-r769-726q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences