Piwigo Reflected XSS vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Piwigo is an open source photo gallery application. Prior to version 14.0.0beta4, a reflected cross-site scripting (XSS) vulnerability is in the` /admin.php?page=plugins&tab=new&installstatus=ok&plugin_id=[here]` page. This vulnerability can be exploited by an attacker to inject malicious HTML and JS code into the HTML page, which could then be executed by admin users when they visit the URL with the payload. The vulnerability is caused by the insecure injection of the `plugin_id` value from the URL into the HTML page. An attacker can exploit this vulnerability by crafting a malicious URL that contains a specially crafted `plugin_id` value. When a victim who is logged in as an administrator visits this URL, the malicious code will be injected into the HTML page and executed. This vulnerability can be exploited by any attacker who has access to a malicious URL. However, only users who are logged in as administrators are affected. This is because the vulnerability is only present on the `/admin.php?page=plugins&tab=new&installstatus=ok&plugin_id=[here]` page, which is only accessible to administrators. Version 14.0.0.beta4 contains a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Piwigo | Piwigo | before 14.0.0beta4 | 14.0.0beta4 | Patch available | CNA |
- Piwigo VendorPiwigo Affected before 14.0.0beta4 Fixed in 14.0.0beta4 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:piwigo:piwigo:*:*:*:*:*:*:*:* | up to 13.8.0 | Vulnerable | Piwigo |
| cpe:2.3:a:piwigo:piwigo:14.0.0:beta1:*:*:*:*:*:* | 14.0.0 beta1 | Vulnerable | Piwigo |
| cpe:2.3:a:piwigo:piwigo:14.0.0:beta2:*:*:*:*:*:* | 14.0.0 beta2 | Vulnerable | Piwigo |
| cpe:2.3:a:piwigo:piwigo:14.0.0:beta3:*:*:*:*:*:* | 14.0.0 beta3 | Vulnerable | Piwigo |
- cpe:2.3:a:piwigo:piwigo:*:*:*:*:*:*:*:* Versions up to 13.8.0 Vulnerable ·Piwigo
- cpe:2.3:a:piwigo:piwigo:14.0.0:beta1:*:*:*:*:*:* Versions 14.0.0 beta1 Vulnerable ·Piwigo
- cpe:2.3:a:piwigo:piwigo:14.0.0:beta2:*:*:*:*:*:* Versions 14.0.0 beta2 Vulnerable ·Piwigo
- cpe:2.3:a:piwigo:piwigo:14.0.0:beta3:*:*:*:*:*:* Versions 14.0.0 beta3 Vulnerable ·Piwigo
Remediation
- Fix · CNA Piwigo (Piwigo) Fixed in 14.0.0beta4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-44393
References
More Piwigo vulnerabilities
- TI-2023-16500 Piwigo 13.6.0 is vulnerable to SQL Injection via in the "profile" function. CVSS 3.1CRITICAL 9.8
- TI-2023-16499 Piwigo 13.6.0 is vulnerable to SQL Injection via /admin/permalinks.php. CVSS 3.1CRITICAL 9.8
- TI-2025-38673 Piwigo is vulnerable to one-click account takeover by modifying the password-reset link CVSS 3.1HIGH 8.8
- TI-2024-32356 Piwigo v14.5.0 was discovered to contain a Cross-Site Request Forgery (CSRF) via the Edit album function. CVSS 3.1HIGH 8.8
- TI-2023-11988 Piwigo before 13.6.0 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1HIGH 8.8
- TI-2026-22184 Piwigo: Unauthenticated Information Disclosure via pwg.history.search API CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences