CloudExplorer Lite permission bypass vulnerability
Priority HIGH 81CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-287.
Summary
CloudExplorer Lite is an open source, lightweight cloud management platform. Prior to version 1.4.1, the gateway filter of CloudExplorer Lite uses a controller with path starting with `matching/API/`, which can cause a permission bypass. Version 1.4.1 contains a patch for this issue.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00735 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed CloudExplorer-Lite (CloudExplorer-Dev): 1.4.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| 1Panel-dev | CloudExplorer-Lite | before 1.4.1 | 1.4.1 | Patch available | CNA |
- CloudExplorer-Lite Vendor1Panel-dev Affected before 1.4.1 Fixed in 1.4.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fit2cloud:cloudexplorer_lite:*:*:*:*:*:*:*:* | before 1.4.1 | Vulnerable | 1Panel-dev |
- cpe:2.3:a:fit2cloud:cloudexplorer_lite:*:*:*:*:*:*:*:* Versions before 1.4.1 Vulnerable ·1Panel-dev
Remediation
- Fix · CNA CloudExplorer-Lite (CloudExplorer-Dev) Fixed in 1.4.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-44397
- 2026-10-31 EPSS moved to the 50th–90th percentile
References
More 1Panel-dev Cloudexplorer Lite vulnerabilities
- TI-2023-20041 Command injection vulnerability in module management function in CloudExplorer Lite CVSS 3.1CRITICAL 9.8
- TI-2023-20651 CloudExplorer Lite sensitive information leakage vulnerability CVSS 3.1HIGH 7.5
- TI-2023-22509 An issue in CloudExplorer Lite 1.3.1 allows an attacker to obtain sensitive information via the login key component. CVSS 3.1HIGH 7.5
- TI-2023-02666 Improper Access Control in cloudexplorer-dev/cloudexplorer-lite CVSS 3.1HIGH 8.1
- TI-2023-27633 Insecure Permissions vulnerability in fit2cloud Cloud Explorer Lite version 1.4.1, allow… CVSS 3.1HIGH 7.8
- TI-2023-02665 Authorization Bypass Through User-Controlled Key in cloudexplorer-dev/cloudexplorer-lite CVSS 3.1MEDIUM 4.9
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences