Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 4 fixed, 7 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-639.
Summary
Authorization Bypass Through User-Controlled Key vulnerability in Apache ZooKeeper. If SASL Quorum Peer authentication is enabled in ZooKeeper (quorum.auth.enableSasl=true), the authorization is done by verifying that the instance part in SASL authentication ID is listed in zoo.cfg server list. The instance part in SASL auth ID is optional and if it's missing, like '[email protected]', the authorization check will be skipped. As a result an arbitrary endpoint could join the cluster and begin propagating counterfeit changes to the leader, essentially giving it complete read-write access to the data tree. Quorum Peer authentication is not enabled by default. Users are recommended to upgrade to version 3.9.1, 3.8.3, 3.7.2, which fixes the issue. Alternately ensure the ensemble election/quorum communication is protected by a firewall as this will mitigate the issue. See the documentation for more details on correct cluster administration.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache ZooKeeper | 3.9.0 to before 3.9.1; 3.8.0 – 3.8.2; 3.7.0 – 3.7.1; before 3.7.0 | 3.9.1 | Patch available | CNA |
| — | org.apache.zookeeper:zookeeper (Maven) | before 3.7.2 | 3.7.2 | Patch available | GHSA-7286-pgfv-vxvh |
| — | org.apache.zookeeper:zookeeper (Maven) | 3.8.0 to before 3.8.3 | 3.8.3 | Patch available | GHSA-7286-pgfv-vxvh |
| — | org.apache.zookeeper:zookeeper (Maven) | 3.9.0 to before 3.9.1 | 3.9.1 | Patch available | GHSA-7286-pgfv-vxvh |
- Apache ZooKeeper VendorApache Affected 3.9.0 to before 3.9.1; 3.8.0 – 3.8.2; 3.7.0 – 3.7.1; before 3.7.0 Fixed in 3.9.1 Patch available CNA
- org.apache.zookeeper:zookeeper (Maven) Vendor— Affected before 3.7.2 Fixed in 3.7.2 Patch available GHSA-7286-pgfv-vxvh
- org.apache.zookeeper:zookeeper (Maven) Vendor— Affected 3.8.0 to before 3.8.3 Fixed in 3.8.3 Patch available GHSA-7286-pgfv-vxvh
- org.apache.zookeeper:zookeeper (Maven) Vendor— Affected 3.9.0 to before 3.9.1 Fixed in 3.9.1 Patch available GHSA-7286-pgfv-vxvh
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:zookeeper:*:*:*:*:*:*:*:* | before 3.7.2; 3.8.0 to before 3.8.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:zookeeper:3.9.0:*:*:*:*:*:*:* | 3.9.0 | Vulnerable | Apache |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* | 12.0 | Vulnerable | Debian |
- cpe:2.3:a:apache:zookeeper:*:*:*:*:*:*:*:* Versions before 3.7.2; 3.8.0 to before 3.8.3 Vulnerable ·Apache
- cpe:2.3:a:apache:zookeeper:3.9.0:*:*:*:*:*:*:* Versions 3.9.0 Vulnerable ·Apache
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* Versions 12.0 Vulnerable ·Debian
Remediation
- Fix · CNA Apache ZooKeeper (Apache Software Foundation) Fixed in 3.9.1
- Fix · GHSA-7286-pgfv-vxvh org.apache.zookeeper:zookeeper (Maven) Fixed in 3.7.2 Advisory →
- Fix · GHSA-7286-pgfv-vxvh org.apache.zookeeper:zookeeper (Maven) Fixed in 3.8.3 Advisory →
- Fix · GHSA-7286-pgfv-vxvh org.apache.zookeeper:zookeeper (Maven) Fixed in 3.9.1 Advisory →
Red Hat 4 advisories
- RHSA-2024:2945 Released 2024-05-21 · Red Hat rating ImportantRed Hat AMQ Broker 7.12.0 release and security update
- Red Hat AMQ Broker 7
- RHSA-2024:0903 Released 2024-02-20 · Red Hat rating ModerateRed Hat AMQ Broker 7.10.6 release and security update
- AMQ Broker 7.10.6
- RHSA-2024:0705 Released 2024-02-06 · Red Hat rating ModerateRed Hat AMQ Broker 7.11.6 release and security update
- Red Hat AMQ Broker 7.11.6
Show 1 more Red Hat advisories
- RHSA-2023:7678 Released 2023-12-06 · Red Hat rating ImportantRed Hat AMQ Streams 2.6.0 release and security update
- Red Hat AMQ Streams 2.6.0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat BPM Suite 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss A-MQ 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss BRMS 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Data Virtualization 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse Service Works 6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Application Runtimes | Affected | No fix planned: Out of support scope |
| AMQ Broker 7.10.6 | Fixed | RHSA-2024:0903 |
| Red Hat AMQ Broker 7 | Fixed | RHSA-2024:2945 |
| Red Hat AMQ Broker 7.11.6 | Fixed | RHSA-2024:0705 |
| Red Hat AMQ Streams 2.6.0 | Fixed | RHSA-2023:7678 |
Not affected: 3 products
- Red Hat Decision Manager 7
- Red Hat Fuse 7
- Red Hat Process Automation 7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-44981
- 2026-10-03 Alias added: GHSA-7286-pgfv-vxvh
References
Advisory 4
More Apache Zookeeper vulnerabilities
- TI-2017-03638 Missing authentication in Apache ZooKeeper CVSS 3.0HIGH 7.5
- TI-2021-04395 Possible request smuggling in HTTP/2 due missing validation CVSS 3.1MEDIUM 5.9
- TI-2024-34425 Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server CVSS 3.1CRITICAL 9.1
- TI-2016-04336 Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before… CVSS 3.0HIGH 8.1
- TI-2018-05789 Missing authorization in Apache ZooKeeper CVSS 3.1HIGH 7.5
- TI-2026-55327 Missing authorization in Apache ZooKeeper CVSS 3.1HIGH 7.5
Sources
- CVE-2023-44981 · CVE Program
- CVE-2023-44981 · NVD
- FIRST EPSS
- GHSA-7286-pgfv-vxvh · GitHub Advisory Database · CC BY 4.0
- CVE-2023-44981 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences