Read the docs
TI-2023-24168 Aliases CVE-2023-45147

Arbitrary keys can be added to a topic's custom fields by any user in Discourse

Priority LOW 22CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.

Summary

Discourse is an open source community platform. In affected versions any user can create a topic and add arbitrary custom fields to a topic. The severity of this vulnerability depends on what plugins are installed and how the plugins uses topic custom fields. For a default Discourse installation with the default plugins, this vulnerability has no impact. The problem has been patched in the latest version of Discourse. Users are advised to update to version 3.1.1 if they are on the stable branch or 3.2.0.beta2 if they are on the beta branch. Users unable to upgrade should disable any plugins that access topic custom fields.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00319 24th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
discoursediscourseup to 3.1.1; beta: <= 3.2.0.beta2—No fix listedCNA
  • discourse Vendordiscourse Affected up to 3.1.1; beta: <= 3.2.0.beta2 Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:*up to 3.1.1Vulnerablediscourse
cpe:2.3:a:discourse:discourse:3.2.0:beta1:*:*:beta:*:*:*3.2.0 beta1Vulnerablediscourse
  • cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:* Versions up to 3.1.1 Vulnerable ·discourse
  • cpe:2.3:a:discourse:discourse:3.2.0:beta1:*:*:beta:*:*:* Versions 3.2.0 beta1 Vulnerable ·discourse

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-45147

References

  • TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
  • TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
  • TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
  • TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
  • TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
  • TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
See all 262 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences