ThingsBoard before 3.5 allows Server-Side Template Injection if users are allowed to…
Priority HIGH 73CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
ThingsBoard before 3.5 allows Server-Side Template Injection if users are allowed to modify an email template, because Apache FreeMarker supports freemarker.template.utility.Execute (for content sent to the /api/admin/settings endpoint).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01049 64th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed org.thingsboard:thingsboard (Maven): 3.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.thingsboard:thingsboard (Maven) | before 3.5 | 3.5 | Patch available | GHSA-6pgr-j9v4-xfvv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.thingsboard:thingsboard (Maven) Vendor— Affected before 3.5 Fixed in 3.5 Patch available GHSA-6pgr-j9v4-xfvv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thingsboard:thingsboard:*:*:*:*:*:*:*:* | before 3.5 | Vulnerable | ThingsBoard |
- cpe:2.3:a:thingsboard:thingsboard:*:*:*:*:*:*:*:* Versions before 3.5 Vulnerable ·ThingsBoard
Remediation
- Fix · GHSA-6pgr-j9v4-xfvv org.thingsboard:thingsboard (Maven) Fixed in 3.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-45303
- 2026-10-03 Alias added: GHSA-6pgr-j9v4-xfvv
References
More Thingsboard vulnerabilities
- TI-2022-18942 Cross Site Scripting (XSS) vulnerability in Things Board 3.4.1 allows remote attackers to… CVSS 3.1CRITICAL 9.6
- TI-2022-23955 ThingsBoard 3.4.1 could allow a remote authenticated attacker to achieve Vertical… CVSS 3.1HIGH 8.8
- TI-2022-22507 An issue was discovered in ThingsBoard 3.4.1, allows low privileged attackers… CVSS 3.1HIGH 8.8
- TI-2020-16789 ThingsBoard before v3.2 is vulnerable to Host header injection in password-reset emails. CVSS 3.1HIGH 8.8
- TI-2025-24420 ThingsBoard < v4.2.1 SVG Image SSRF CVSS 4.0MEDIUM 6.9
- TI-2023-11609 ThingsBoard 3.4.1 could allow a remote attacker to gain elevated privileges because… CVSS 3.1HIGH 8.1
Sources
- CVE-2023-45303 · CVE Program
- CVE-2023-45303 · NVD
- FIRST EPSS
- GHSA-6pgr-j9v4-xfvv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences