Read the docs
TI-2023-24306 Aliases CVE-2023-45348GHSA-fpxx-xv4c-gxqp

Apache Airflow: Configuration information leakage vulnerability

Priority LOW 23CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive configuration information when the "expose_config" option is set to "non-sensitive-only". The `expose_config` option is False by default. It is recommended to upgrade to a version that is not affected.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.016 75th percentileScored 2026-11-07
Fix Fixed Apache Airflow (Apache Software Foundation): 2.7.2apache-airflow (PyPI): 2.7.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Airflow2.7.0 to before 2.7.22.7.2Patch availableCNA
—apache-airflow (PyPI)2.7.0 to before 2.7.22.7.2Patch availableGHSA-fpxx-xv4c-gxqp
  • Apache Airflow VendorApache Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available CNA
  • apache-airflow (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-fpxx-xv4c-gxqp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*2.7.0 to before 2.7.2VulnerableApache
  • cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.2 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Airflow (Apache Software Foundation) Fixed in 2.7.2
  • Fix · GHSA-fpxx-xv4c-gxqp apache-airflow (PyPI) Fixed in 2.7.2 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Airflow 2.7.2

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2023-22883 Apache Airflow: Improper access control to DAG resourcesPriority LOW 33
    • TI-2023-22767 Apache Airflow: Bypass permission verification to view task instances of other dagsPriority LOW 33
    • TI-2023-22871 Apache Airflow: Improper access control vulnerability in the "List dag warnings" featurePriority LOW 32

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-45348
  2. 2026-10-03 Alias added: GHSA-fpxx-xv4c-gxqp

References

  • TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
  • TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
  • TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
  • TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
  • TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
See all 157 →

Sources