An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-835.
Summary
An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mediawiki/core (Packagist) | before 1.35.12 | 1.35.12 | Patch available | GHSA-w5fx-cx7f-6vr9 |
| — | mediawiki/core (Packagist) | 1.36.0 to before 1.39.5 | 1.39.5 | Patch available | GHSA-w5fx-cx7f-6vr9 |
| — | mediawiki/core (Packagist) | 1.40.0 to before 1.40.1 | 1.40.1 | Patch available | GHSA-w5fx-cx7f-6vr9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mediawiki/core (Packagist) Vendor— Affected before 1.35.12 Fixed in 1.35.12 Patch available GHSA-w5fx-cx7f-6vr9
- mediawiki/core (Packagist) Vendor— Affected 1.36.0 to before 1.39.5 Fixed in 1.39.5 Patch available GHSA-w5fx-cx7f-6vr9
- mediawiki/core (Packagist) Vendor— Affected 1.40.0 to before 1.40.1 Fixed in 1.40.1 Patch available GHSA-w5fx-cx7f-6vr9
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | before 1.35.12; 1.36.0 to before 1.39.5 | Vulnerable | mediawiki |
| cpe:2.3:a:mediawiki:mediawiki:1.40.0:-:*:*:*:*:*:* | 1.40.0 | Vulnerable | mediawiki |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* | 12.0 | Vulnerable | Debian |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions before 1.35.12; 1.36.0 to before 1.39.5 Vulnerable ·mediawiki
- cpe:2.3:a:mediawiki:mediawiki:1.40.0:-:*:*:*:*:*:* Versions 1.40.0 Vulnerable ·mediawiki
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* Versions 12.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-w5fx-cx7f-6vr9 mediawiki/core (Packagist) Fixed in 1.35.12 Advisory →
- Fix · GHSA-w5fx-cx7f-6vr9 mediawiki/core (Packagist) Fixed in 1.39.5 Advisory →
- Fix · GHSA-w5fx-cx7f-6vr9 mediawiki/core (Packagist) Fixed in 1.40.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-45363
- 2026-10-03 Alias added: GHSA-w5fx-cx7f-6vr9
References
Sources
- CVE-2023-45363 · CVE Program
- CVE-2023-45363 · NVD
- FIRST EPSS
- GHSA-w5fx-cx7f-6vr9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences