XSS vulnerability in Pilz PASvisu and PMI v8xx
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A stored cross-site scripting vulnerability in the Runtime component of Pilz PASvisu before 1.14.1 and PMI v8xx up to and including 2.0.33992 allows a low-privileged remote unauthenticated attacker to manipulate process data with potential impact on integrity and/or availability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA PASvisu (Pilz) Fixed in 1.14.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Pilz PASvisu, PMI v8xx — certvde.com/en/advisories/VDE-2023-050
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-24557 Pilz: XSS vulnerability in Pilz PASvisu and PMI v8xxPriority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2023-45796
- 2026-10-03 Alias added: GHSA-462c-92rv-647m
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
More Pilz vulnerabilities
- TI-2025-27622 Pilz: Missing Authentication in Node-RED integration CVSS 3.1CRITICAL 10.0
- TI-2025-27614 Pilz: Authentication Bypass in IndustrialPI Webstatus CVSS 3.1CRITICAL 9.8
- TI-2022-19518 PILZ: PASvisu and PMI affected by ZipSlip CVSS 3.1HIGH 7.5
- TI-2020-09719 In Pilz PMC programming tool 3.x before 3.5.17 (based on CODESYS Development System), a… CVSS 3.1HIGH 7.5
- TI-2023-24557 Pilz: XSS vulnerability in Pilz PASvisu and PMI v8xx CVSS 3.1HIGH 7.8
- TI-2020-09721 CODESYS V3 prone to Inadequate Password Hashing CVSS 3.1HIGH 7.8
Sources
- CVE-2023-45796 · CVE Program
- CVE-2023-45796 · NVD
- FIRST EPSS
- GHSA-462c-92rv-647m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences