Updater Private Keys Possibly Leaked via Vite Environment Variables in tauri-cli
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Tauri is a framework for building binaries for all major desktop platforms. This advisory is not describing a vulnerability in the Tauri code base itself but a commonly used misconfiguration which could lead to leaking of the private key and updater key password into bundled Tauri applications using the Vite frontend in a specific configuration. The Tauri documentation used an insecure example configuration in the `Vite guide` to showcase how to use Tauri together with Vite. Copying the following snippet `envPrefix: ['VITE_', 'TAURI_'],` from this guide into the `vite.config.ts` of a Tauri project leads to bundling the `TAURI_PRIVATE_KEY` and `TAURI_KEY_PASSWORD` into the Vite frontend code and therefore leaking this value to the released Tauri application. Using the `envPrefix: ['VITE_'],` or any other framework than Vite means you are not impacted by this advisory. Users are advised to rotate their updater private key if they are affected by this (requires Tauri CLI >=1.5.5). After updating the envPrefix configuration, generate a new private key with `tauri signer generate`, saving the new private key and updating the updater's `pubkey` value on `tauri.conf.json` with the new public key. To update your existing application, the next application build must be signed with the older private key in order to be accepted by the existing application.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tauri-apps | tauri | 2.0.0-alpha.0 to before 2.0.0-alpha.16; 1.0.0 to before 1.5.6 | 2.0.0-alpha.16, 1.5.6 | Patch available | CNA |
| — | tauri-cli (crates.io) | 2.0.0-alpha.0 to before 2.0.0-alpha.16 | 2.0.0-alpha.16 | Patch available | GHSA-2rcp-jvr4-r259 |
| — | @tauri-apps/cli (npm) | 2.0.0-alpha.0 to before 2.0.0-alpha.16 | 2.0.0-alpha.16 | Patch available | GHSA-2rcp-jvr4-r259 |
| — | @tauri-apps/cli (npm) | 1.0.0 to before 1.5.6 | 1.5.6 | Patch available | GHSA-2rcp-jvr4-r259 |
| — | tauri-cli (crates.io) | 1.0.0 to before 1.5.6 | 1.5.6 | Patch available | GHSA-2rcp-jvr4-r259 |
- tauri Vendortauri-apps Affected 2.0.0-alpha.0 to before 2.0.0-alpha.16; 1.0.0 to before 1.5.6 Fixed in 2.0.0-alpha.16, 1.5.6 Patch available CNA
- tauri-cli (crates.io) Vendor— Affected 2.0.0-alpha.0 to before 2.0.0-alpha.16 Fixed in 2.0.0-alpha.16 Patch available GHSA-2rcp-jvr4-r259
- @tauri-apps/cli (npm) Vendor— Affected 2.0.0-alpha.0 to before 2.0.0-alpha.16 Fixed in 2.0.0-alpha.16 Patch available GHSA-2rcp-jvr4-r259
- @tauri-apps/cli (npm) Vendor— Affected 1.0.0 to before 1.5.6 Fixed in 1.5.6 Patch available GHSA-2rcp-jvr4-r259
- tauri-cli (crates.io) Vendor— Affected 1.0.0 to before 1.5.6 Fixed in 1.5.6 Patch available GHSA-2rcp-jvr4-r259
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tauri:tauri:*:*:*:*:*:*:*:* | before 2.0.0 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha0:*:*:*:*:*:* | 2.0.0 alpha0 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha10:*:*:*:*:*:* | 2.0.0 alpha10 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha11:*:*:*:*:*:* | 2.0.0 alpha11 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha12:*:*:*:*:*:* | 2.0.0 alpha12 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha13:*:*:*:*:*:* | 2.0.0 alpha13 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha14:*:*:*:*:*:* | 2.0.0 alpha14 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha15:*:*:*:*:*:* | 2.0.0 alpha15 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha2:*:*:*:*:*:* | 2.0.0 alpha2 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha3:*:*:*:*:*:* | 2.0.0 alpha3 | Vulnerable | tauri-apps |
- cpe:2.3:a:tauri:tauri:*:*:*:*:*:*:*:* Versions before 2.0.0 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha0:*:*:*:*:*:* Versions 2.0.0 alpha0 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha10:*:*:*:*:*:* Versions 2.0.0 alpha10 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha11:*:*:*:*:*:* Versions 2.0.0 alpha11 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha12:*:*:*:*:*:* Versions 2.0.0 alpha12 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha13:*:*:*:*:*:* Versions 2.0.0 alpha13 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha14:*:*:*:*:*:* Versions 2.0.0 alpha14 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha15:*:*:*:*:*:* Versions 2.0.0 alpha15 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha2:*:*:*:*:*:* Versions 2.0.0 alpha2 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha3:*:*:*:*:*:* Versions 2.0.0 alpha3 Vulnerable ·tauri-apps
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tauri:tauri:2.0.0:alpha4:*:*:*:*:*:* | 2.0.0 alpha4 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha5:*:*:*:*:*:* | 2.0.0 alpha5 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha6:*:*:*:*:*:* | 2.0.0 alpha6 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha7:*:*:*:*:*:* | 2.0.0 alpha7 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha8:*:*:*:*:*:* | 2.0.0 alpha8 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:tauri:2.0.0:alpha9:*:*:*:*:*:* | 2.0.0 alpha9 | Vulnerable | tauri-apps |
- cpe:2.3:a:tauri:tauri:2.0.0:alpha4:*:*:*:*:*:* Versions 2.0.0 alpha4 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha5:*:*:*:*:*:* Versions 2.0.0 alpha5 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha6:*:*:*:*:*:* Versions 2.0.0 alpha6 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha7:*:*:*:*:*:* Versions 2.0.0 alpha7 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha8:*:*:*:*:*:* Versions 2.0.0 alpha8 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:tauri:2.0.0:alpha9:*:*:*:*:*:* Versions 2.0.0 alpha9 Vulnerable ·tauri-apps
Remediation
- Fix · CNA tauri (tauri-apps) Fixed in 2.0.0-alpha.16, 1.5.6
- Fix · GHSA-2rcp-jvr4-r259 tauri-cli (crates.io) Fixed in 2.0.0-alpha.16 Advisory →
- Fix · GHSA-2rcp-jvr4-r259 @tauri-apps/cli (npm) Fixed in 2.0.0-alpha.16 Advisory →
- Fix · GHSA-2rcp-jvr4-r259 @tauri-apps/cli (npm) Fixed in 1.5.6 Advisory →
- Fix · GHSA-2rcp-jvr4-r259 tauri-cli (crates.io) Fixed in 1.5.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46115
- 2026-10-03 Alias added: GHSA-2rcp-jvr4-r259
References
Advisory 2
Other 5
More tauri-apps Tauri vulnerabilities
- TI-2022-18594 The readDir Endpoint Scope can be Bypassed With Symbolic Links in Tauri CVSS 3.1HIGH 8.3
- TI-2022-22815 Tauri vulnerable to path traversal CVSS 3.1HIGH 7.7
- TI-2026-30506 Tauri: Origin Confusion Allows Remote Pages to Invoke Local-Only IPC Commands CVSS 4.0MEDIUM 6.1
- TI-2023-17285 Tauri vulnerable to Regression on Filesystem Scope Checks for Dotfiles CVSS 3.1CRITICAL 9.8
- TI-2023-14844 Tauri Open Redirect Vulnerability Possibly Exposes IPC to External Sites CVSS 3.1MEDIUM 5.4
- TI-2022-20215 Tauri Filesystem Scope can be Partially Bypassed CVSS 3.1MEDIUM 4.7
Sources
- CVE-2023-46115 · CVE Program
- CVE-2023-46115 · NVD
- FIRST EPSS
- GHSA-2rcp-jvr4-r259 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences