Denial of Service by publishing large messages over the HTTP API
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 fixed, 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
RabbitMQ is a multi-protocol messaging and streaming broker. HTTP API did not enforce an HTTP request body limit, making it vulnerable for denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish a very large messages over the HTTP API and cause target node to be terminated by an "out-of-memory killer"-like mechanism. This vulnerability has been patched in versions 3.11.24 and 3.12.7.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rabbitmq | rabbitmq-server | before 3.12.7; before 3.11.24 | 3.12.7, 3.11.24 | Patch available | CNA |
| — | rabbit_common (Hex) | 3.12.0 to before 3.12.7 | 3.12.7 | Patch available | GHSA-w6cq-9cf4-gqpg |
| — | rabbit_common (Hex) | 3.11.0 to before 3.11.24 | 3.11.24 | Patch available | GHSA-w6cq-9cf4-gqpg |
- rabbitmq-server Vendorrabbitmq Affected before 3.12.7; before 3.11.24 Fixed in 3.12.7, 3.11.24 Patch available CNA
- rabbit_common (Hex) Vendor— Affected 3.12.0 to before 3.12.7 Fixed in 3.12.7 Patch available GHSA-w6cq-9cf4-gqpg
- rabbit_common (Hex) Vendor— Affected 3.11.0 to before 3.11.24 Fixed in 3.11.24 Patch available GHSA-w6cq-9cf4-gqpg
Remediation
- Fix · CNA rabbitmq-server (rabbitmq) Fixed in 3.12.7, 3.11.24
- Fix · GHSA-w6cq-9cf4-gqpg rabbit_common (Hex) Fixed in 3.12.7 Advisory →
- Fix · GHSA-w6cq-9cf4-gqpg rabbit_common (Hex) Fixed in 3.11.24 Advisory →
Red Hat 1 advisory
- RHSA-2024:0217 Released 2024-01-16 · Red Hat rating ModerateRed Hat OpenStack Platform 17.1 (rabbitmq-server) security update
- Red Hat OpenStack Platform 17.1 rabbitmq-server-3.9.10-3.el9ost
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 16.1 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 16.2 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 18.0 | Affected | No fix yet |
| Red Hat OpenStack Platform 17.1 | Fixed | RHSA-2024:0217 |
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46118
- 2026-10-03 Alias added: GHSA-w6cq-9cf4-gqpg
References
Advisory 2
More rabbitmq vulnerabilities
- TI-2026-41154 Improper authentication in rabbitmq-server CVSS 3.1CRITICAL 10.0
- TI-2026-41149 RabbitMQ: UNC SSRF affecting the management UI on Windows CVSS 3.1CRITICAL 10.0
- TI-2026-41158 Resource allocation without limits in rabbitmq-server CVSS 3.1HIGH 7.5
- TI-2026-47695 RabbitMQ: OAuth2 Client Secret Exposed via Unauthenticated JavaScript Endpoint CVSS 4.0HIGH 8.2
- TI-2026-47694 RabbitMQ: JWKS Fetch Ignores HTTP Response Status Code - Signing Key Destruction Causes Authentication DoS CVSS 4.0HIGH 8.2
- TI-2026-45167 RabbitMQ Java client: Unvalidated Class.forName in JSON-RPC ProcedureDescription enables arbitrary class loading CVSS 4.0HIGH 7.5
Sources
- CVE-2023-46118 · CVE Program
- CVE-2023-46118 · NVD
- FIRST EPSS
- GHSA-w6cq-9cf4-gqpg · GitHub Advisory Database · CC BY 4.0
- CVE-2023-46118 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences