Overwrite of builtin Cody commands facilitates RCE
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Cody is an artificial intelligence (AI) coding assistant. The Cody AI VSCode extension versions 0.10.0 through 0.14.0 are vulnerable to Remote Code Execution under certain conditions. An attacker in control of a malicious repository could modify the Cody configuration file `.vscode/cody.json` and overwrite Cody commands. If a user with the extension installed opens this malicious repository and runs a Cody command such as /explain or /doc, this could allow arbitrary code execution on the user's machine. The vulnerability is rated as critical severity, but with low exploitability. It requires the user to have a malicious repository loaded and execute the overwritten command in VS Code. The issue is exploitable regardless of the user blocking code execution on a repository through VS Code Workspace Trust. The issue was found during a regular 3rd party penetration test. The maintainers of Cody do not have evidence of open source repositories having malicious `.vscode/cody.json` files to exploit this vulnerability. The issue is fixed in version 0.14.1 of the Cody VSCode extension. In case users can't promptly upgrade, they should not open any untrusted repositories with the Cody extension loaded.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| sourcegraph | cody | 0.10.0 to before 0.14.1 | 0.14.1 | Patch available | CNA |
- cody Vendorsourcegraph Affected 0.10.0 to before 0.14.1 Fixed in 0.14.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sourcegraph:cody:*:*:*:*:*:*:*:* | 0.10.0 – 0.14.0 | Vulnerable | sourcegraph |
- cpe:2.3:a:sourcegraph:cody:*:*:*:*:*:*:*:* Versions 0.10.0 – 0.14.0 Vulnerable ·sourcegraph
Remediation
- Fix · CNA cody (sourcegraph) Fixed in 0.14.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46248
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences