Read the docs
TI-2023-24908 Aliases CVE-2023-46288GHSA-9qqg-mh7c-chfq

Apache Airflow: Sensitive parameters exposed in API when "non-sensitive-only" configuration is set

Priority LOW 24CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Airflow.This issue affects Apache Airflow from 2.4.0 to 2.7.0. Sensitive configuration information has been exposed to authenticated users with the ability to read configuration via Airflow REST API for configuration even when the expose_config option is set to non-sensitive-only. The expose_config option is False by default. It is recommended to upgrade to a version that is not affected if you set expose_config to non-sensitive-only configuration. This is a different error than CVE-2023-45348 which allows authenticated user to retrieve individual configuration values in 2.7.* by specially crafting their request (solved in 2.7.2). Users are recommended to upgrade to version 2.7.2, which fixes the issue and additionally fixes CVE-2023-45348.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01839 79th percentileScored 2026-11-07
Fix Fixed Apache Airflow (Apache Software Foundation): 2.7.0apache-airflow (PyPI): 2.7.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Airflow2.4.0 to before 2.7.02.7.0Patch availableCNA
—apache-airflow (PyPI)2.4.0 to before 2.7.22.7.2Patch availableGHSA-9qqg-mh7c-chfq
  • Apache Airflow VendorApache Affected 2.4.0 to before 2.7.0 Fixed in 2.7.0 Patch available CNA
  • apache-airflow (PyPI) Vendor— Affected 2.4.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-9qqg-mh7c-chfq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*2.4.0 to before 2.7.0VulnerableApache
  • cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:* Versions 2.4.0 to before 2.7.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Airflow (Apache Software Foundation) Fixed in 2.7.0
  • Fix · GHSA-9qqg-mh7c-chfq apache-airflow (PyPI) Fixed in 2.7.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-46288
  2. 2026-10-03 Alias added: GHSA-9qqg-mh7c-chfq

References

  • TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
  • TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
  • TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
  • TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
  • TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
See all 157 →

Sources