Cross Site Scripting vulnerability in EverShop NPM versions before v.1.0.0-rc.5 allows a…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting vulnerability in EverShop NPM versions before v.1.0.0-rc.5 allows a remote attacker to obtain sensitive information via a crafted request to the ProductGrid function in admin/productGrid/Grid.jsx.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00494 42nd percentileScored 2026-11-07
Fix Fixed @evershop/evershop (npm): 1.0.0-rc.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | @evershop/evershop (npm) | before 1.0.0-rc.5 | 1.0.0-rc.5 | Patch available | GHSA-m6vm-ff9v-jp3r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- @evershop/evershop (npm) Vendor— Affected before 1.0.0-rc.5 Fixed in 1.0.0-rc.5 Patch available GHSA-m6vm-ff9v-jp3r
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:evershop:evershop:1.0.0:beta:*:*:*:node.js:*:* | 1.0.0 beta | Vulnerable | Evershop |
| cpe:2.3:a:evershop:evershop:1.0.0:beta1:*:*:*:node.js:*:* | 1.0.0 beta1 | Vulnerable | Evershop |
| cpe:2.3:a:evershop:evershop:1.0.0:beta2:*:*:*:node.js:*:* | 1.0.0 beta2 | Vulnerable | Evershop |
| cpe:2.3:a:evershop:evershop:1.0.0:beta3:*:*:*:node.js:*:* | 1.0.0 beta3 | Vulnerable | Evershop |
| cpe:2.3:a:evershop:evershop:1.0.0:beta4:*:*:*:node.js:*:* | 1.0.0 beta4 | Vulnerable | Evershop |
| cpe:2.3:a:evershop:evershop:1.0.0:beta5:*:*:*:node.js:*:* | 1.0.0 beta5 | Vulnerable | Evershop |
| cpe:2.3:a:evershop:evershop:1.0.0:rc1:*:*:*:node.js:*:* | 1.0.0 rc1 | Vulnerable | Evershop |
| cpe:2.3:a:evershop:evershop:1.0.0:rc2:*:*:*:node.js:*:* | 1.0.0 rc2 | Vulnerable | Evershop |
| cpe:2.3:a:evershop:evershop:1.0.0:rc3:*:*:*:node.js:*:* | 1.0.0 rc3 | Vulnerable | Evershop |
- cpe:2.3:a:evershop:evershop:1.0.0:beta:*:*:*:node.js:*:* Versions 1.0.0 beta Vulnerable ·Evershop
- cpe:2.3:a:evershop:evershop:1.0.0:beta1:*:*:*:node.js:*:* Versions 1.0.0 beta1 Vulnerable ·Evershop
- cpe:2.3:a:evershop:evershop:1.0.0:beta2:*:*:*:node.js:*:* Versions 1.0.0 beta2 Vulnerable ·Evershop
- cpe:2.3:a:evershop:evershop:1.0.0:beta3:*:*:*:node.js:*:* Versions 1.0.0 beta3 Vulnerable ·Evershop
- cpe:2.3:a:evershop:evershop:1.0.0:beta4:*:*:*:node.js:*:* Versions 1.0.0 beta4 Vulnerable ·Evershop
- cpe:2.3:a:evershop:evershop:1.0.0:beta5:*:*:*:node.js:*:* Versions 1.0.0 beta5 Vulnerable ·Evershop
- cpe:2.3:a:evershop:evershop:1.0.0:rc1:*:*:*:node.js:*:* Versions 1.0.0 rc1 Vulnerable ·Evershop
- cpe:2.3:a:evershop:evershop:1.0.0:rc2:*:*:*:node.js:*:* Versions 1.0.0 rc2 Vulnerable ·Evershop
- cpe:2.3:a:evershop:evershop:1.0.0:rc3:*:*:*:node.js:*:* Versions 1.0.0 rc3 Vulnerable ·Evershop
Remediation
- Fix · GHSA-m6vm-ff9v-jp3r @evershop/evershop (npm) Fixed in 1.0.0-rc.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46494
- 2026-10-03 Alias added: GHSA-m6vm-ff9v-jp3r
References
Advisory 2
More Evershop vulnerabilities
- TI-2025-40481 EverShop 2.0.1 allows a remote unauthenticated attacker to upload arbitrary files and… CVSS 3.1HIGH 7.5
- TI-2025-11836 EverShop Order Order.resolvers.js resource injection CVSS 4.0MEDIUM 6.3
- TI-2026-22548 EverShop Vulnerable to Arbitrary Customer Account Takeover via Exposure of Password Reset Token in API Response CVSS 3.1CRITICAL 9.8
- TI-2023-25344 An issue was discovered in NPM's package @evershop/evershop before version 1.0.0-rc.8. CVSS 3.1CRITICAL 9.1
- TI-2026-21008 EverShop has a Second-Order SQL Injection in URL Rewrite Processing Derived from Category URL Keys CVSS 4.0CRITICAL 9.3
- TI-2023-25039 An issue in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-46494 · CVE Program
- CVE-2023-46494 · NVD
- FIRST EPSS
- GHSA-m6vm-ff9v-jp3r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences