Insufficiently protected credentials in Jenkins Warnings Plugin
Priority LOW 30CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure permission to access and capture credentials they are not entitled to. This fix has been backported to 10.4.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00753 55th percentileScored 2026-11-07
Fix Fixed Jenkins Warnings Plugin (Jenkins Project): 10.5.1, 10.4.1io.jenkins.plugins:warnings-ng (Maven): 10.5.1, 10.4.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Warnings Plugin | — | 10.5.1, 10.4.1 | Patch available | CNA |
| — | io.jenkins.plugins:warnings-ng (Maven) | 10.5.0 to before 10.5.1 | 10.5.1 | Patch available | GHSA-66hv-fhcm-7xm7 |
| — | io.jenkins.plugins:warnings-ng (Maven) | before 10.4.1 | 10.4.1 | Patch available | GHSA-66hv-fhcm-7xm7 |
- Jenkins Warnings Plugin VendorJenkins Affected — Fixed in 10.5.1, 10.4.1 Patch available CNA
- io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected 10.5.0 to before 10.5.1 Fixed in 10.5.1 Patch available GHSA-66hv-fhcm-7xm7
- io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected before 10.4.1 Fixed in 10.4.1 Patch available GHSA-66hv-fhcm-7xm7
Remediation
- Fix · CNA Jenkins Warnings Plugin (Jenkins Project) Fixed in 10.5.1, 10.4.1
- Fix · GHSA-66hv-fhcm-7xm7 io.jenkins.plugins:warnings-ng (Maven) Fixed in 10.5.1 Advisory →
- Fix · GHSA-66hv-fhcm-7xm7 io.jenkins.plugins:warnings-ng (Maven) Fixed in 10.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46651
- 2026-10-03 Alias added: GHSA-66hv-fhcm-7xm7
- 2026-10-26 EPSS moved to the 50th–90th percentile
References
Advisory 3
More Jenkins Warnings vulnerabilities
- TI-2019-15852 Cross-site request forgery in Jenkins Warnings Plugin CVSS 3.0HIGH 8.8
- TI-2020-02157 Cross-site request forgery in Jenkins Warnings Plugin CVSS 3.1HIGH 8.8
- TI-2018-15674 Jenkins Warnings Plugin 4.64 and earlier processes XML external entities in files it… CVSS 3.0HIGH 8.8
Sources
- CVE-2023-46651 · CVE Program
- CVE-2023-46651 · NVD
- FIRST EPSS
- GHSA-66hv-fhcm-7xm7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences