FoodCoopShop Server-Side Request Forgery vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
FoodCoopShop is open source software for food coops and local shops. Versions starting with 3.2.0 prior to 3.6.1 are vulnerable to server-side request forgery. In the Network module, a manufacturer account can use the `/api/updateProducts.json` endpoint to make the server send a request to an arbitrary host. This means that the server can be used as a proxy into the internal network where the server is. Furthermore, the checks on a valid image are not adequate, leading to a time of check time of use issue. For example, by using a custom server that returns 200 on HEAD requests, then return a valid image on first GET request and then a 302 redirect to final target on second GET request, the server will copy whatever file is at the redirect destination, making this a full SSRF. Version 3.6.1 fixes this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| foodcoopshop | foodcoopshop | 3.2.0 to before 3.6.1 | 3.6.1 | Patch available | CNA |
| — | foodcoopshop/foodcoopshop (Packagist) | 3.2.0 to before 3.6.1 | 3.6.1 | Patch available | GHSA-jhww-fx2j-3rf7 |
- foodcoopshop Vendorfoodcoopshop Affected 3.2.0 to before 3.6.1 Fixed in 3.6.1 Patch available CNA
- foodcoopshop/foodcoopshop (Packagist) Vendor— Affected 3.2.0 to before 3.6.1 Fixed in 3.6.1 Patch available GHSA-jhww-fx2j-3rf7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:foodcoopshop:foodcoopshop:*:*:*:*:*:*:*:* | 3.2.0 – 3.6.0 | Vulnerable | foodcoopshop |
- cpe:2.3:a:foodcoopshop:foodcoopshop:*:*:*:*:*:*:*:* Versions 3.2.0 – 3.6.0 Vulnerable ·foodcoopshop
Remediation
- Fix · CNA foodcoopshop (foodcoopshop) Fixed in 3.6.1
- Fix · GHSA-jhww-fx2j-3rf7 foodcoopshop/foodcoopshop (Packagist) Fixed in 3.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46725
- 2026-10-03 Alias added: GHSA-jhww-fx2j-3rf7
References
Patch 2
Advisory 2
Sources
- CVE-2023-46725 · CVE Program
- CVE-2023-46725 · NVD
- FIRST EPSS
- GHSA-jhww-fx2j-3rf7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences