Symfony potential Cross-site Scripting vulnerabilities in CodeExtension filters
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 2.0.0, 5.0.0, and 6.0.0 and prior to versions 4.4.51, 5.4.31, and 6.3.8, some Twig filters in CodeExtension use `is_safe=html` but don't actually ensure their input is safe. As of versions 4.4.51, 5.4.31, and 6.3.8, Symfony now escapes the output of the affected filters.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 2.0.0 to before 4.4.51; 5.0.0 to before 5.4.31; 6.0.0 to before 6.3.8 | 4.4.51, 5.4.31, 6.3.8 | Patch available | CNA |
| — | symfony/twig-bridge (Packagist) | 2.0.0 to before 4.4.51 | 4.4.51 | Patch available | GHSA-q847-2q57-wmr3 |
| — | symfony/twig-bridge (Packagist) | 5.0.0 to before 5.4.31 | 5.4.31 | Patch available | GHSA-q847-2q57-wmr3 |
| — | symfony/twig-bridge (Packagist) | 6.0.0 to before 6.3.8 | 6.3.8 | Patch available | GHSA-q847-2q57-wmr3 |
| — | symfony/symfony (Packagist) | 2.0.0 to before 4.4.51 | 4.4.51 | Patch available | GHSA-q847-2q57-wmr3 |
| — | symfony/symfony (Packagist) | 5.0.0 to before 5.4.31 | 5.4.31 | Patch available | GHSA-q847-2q57-wmr3 |
| — | symfony/symfony (Packagist) | 6.0.0 to before 6.3.8 | 6.3.8 | Patch available | GHSA-q847-2q57-wmr3 |
- symfony Vendorsymfony Affected 2.0.0 to before 4.4.51; 5.0.0 to before 5.4.31; 6.0.0 to before 6.3.8 Fixed in 4.4.51, 5.4.31, 6.3.8 Patch available CNA
- symfony/twig-bridge (Packagist) Vendor— Affected 2.0.0 to before 4.4.51 Fixed in 4.4.51 Patch available GHSA-q847-2q57-wmr3
- symfony/twig-bridge (Packagist) Vendor— Affected 5.0.0 to before 5.4.31 Fixed in 5.4.31 Patch available GHSA-q847-2q57-wmr3
- symfony/twig-bridge (Packagist) Vendor— Affected 6.0.0 to before 6.3.8 Fixed in 6.3.8 Patch available GHSA-q847-2q57-wmr3
- symfony/symfony (Packagist) Vendor— Affected 2.0.0 to before 4.4.51 Fixed in 4.4.51 Patch available GHSA-q847-2q57-wmr3
- symfony/symfony (Packagist) Vendor— Affected 5.0.0 to before 5.4.31 Fixed in 5.4.31 Patch available GHSA-q847-2q57-wmr3
- symfony/symfony (Packagist) Vendor— Affected 6.0.0 to before 6.3.8 Fixed in 6.3.8 Patch available GHSA-q847-2q57-wmr3
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.0.0 to before 4.4.51; 5.0.0 to before 5.4.31; 6.0.0 to before 6.3.8 | Vulnerable | sensiolabs |
| cpe:2.3:a:symfony:twig-bridge:*:*:*:*:*:*:*:* | 2.0.0 to before 4.4.51; 5.0.0 to before 5.4.31; 6.0.0 to before 6.3.8 | Vulnerable | symfony |
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.0.0 to before 4.4.51; 5.0.0 to before 5.4.31; 6.0.0 to before 6.3.8 Vulnerable ·sensiolabs
- cpe:2.3:a:symfony:twig-bridge:*:*:*:*:*:*:*:* Versions 2.0.0 to before 4.4.51; 5.0.0 to before 5.4.31; 6.0.0 to before 6.3.8 Vulnerable ·symfony
Remediation
- Fix · CNA symfony (symfony) Fixed in 4.4.51, 5.4.31, 6.3.8
- Fix · GHSA-q847-2q57-wmr3 symfony/twig-bridge (Packagist) Fixed in 4.4.51 Advisory →
- Fix · GHSA-q847-2q57-wmr3 symfony/twig-bridge (Packagist) Fixed in 5.4.31 Advisory →
- Fix · GHSA-q847-2q57-wmr3 symfony/twig-bridge (Packagist) Fixed in 6.3.8 Advisory →
- Fix · GHSA-q847-2q57-wmr3 symfony/symfony (Packagist) Fixed in 4.4.51 Advisory →
- Fix · GHSA-q847-2q57-wmr3 symfony/symfony (Packagist) Fixed in 5.4.31 Advisory →
- Fix · GHSA-q847-2q57-wmr3 symfony/symfony (Packagist) Fixed in 6.3.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46734
- 2026-10-03 Alias added: GHSA-q847-2q57-wmr3
References
Patch 2
Advisory 2
Sources
- CVE-2023-46734 · CVE Program
- CVE-2023-46734 · NVD
- FIRST EPSS
- GHSA-q847-2q57-wmr3 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-46734 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences