Read the docs
TI-2023-25274 Aliases CVE-2023-46801GHSA-jjvc-v8gw-5255

Apache Linkis DataSource: DataSource Remote code execution vulnerability

Priority MEDIUM 43CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

In Apache Linkis <= 1.5.0, data source management module, when adding Mysql data source, exists remote code execution vulnerability for java version < 1.8.0_241. The deserialization vulnerability exploited through jrmp can inject malicious files into the server and execute them. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out.  We recommend that users upgrade the java version to >= 1.8.0_241. Or users upgrade Linkis to version 1.6.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01228 69th percentileScored 2026-11-07
Fix Fixed Apache Linkis DataSource (Apache Software Foundation): 1.6.0org.apache.linkis:linkis-datasource (Maven): 1.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Linkis DataSource1.4.0 to before 1.6.01.6.0Patch availableCNA
—org.apache.linkis:linkis-datasource (Maven)1.4.0 to before 1.6.01.6.0Patch availableGHSA-jjvc-v8gw-5255
  • Apache Linkis DataSource VendorApache Affected 1.4.0 to before 1.6.0 Fixed in 1.6.0 Patch available CNA
  • org.apache.linkis:linkis-datasource (Maven) Vendor— Affected 1.4.0 to before 1.6.0 Fixed in 1.6.0 Patch available GHSA-jjvc-v8gw-5255

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:linkis:*:*:*:*:*:*:*:*1.4.0 to before 1.6.0VulnerableApache
  • cpe:2.3:a:apache:linkis:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.6.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Linkis DataSource (Apache Software Foundation) Fixed in 1.6.0
  • Fix · GHSA-jjvc-v8gw-5255 org.apache.linkis:linkis-datasource (Maven) Fixed in 1.6.0 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Linkis DataSource 1.6.0

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2023-27067 Apache Linkis DataSource: JDBC Datasource Module with DB2 has JNDI Injection vulnerabilityPriority MEDIUM 40

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-46801
  2. 2026-10-03 Alias added: GHSA-jjvc-v8gw-5255

References

  • TI-2023-13644 Apache Linkis DatasourceManager module has a deserialization command execution CVSS 3.1CRITICAL 9.8
  • TI-2023-13643 Apache Linkis JDBC EngineCon has a deserialization command execution CVSS 3.1CRITICAL 9.8
  • TI-2023-12312 Apache Linkis publicsercice module unrestricted upload of file CVSS 3.1CRITICAL 9.8
  • TI-2023-12313 Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue CVSS 3.1CRITICAL 9.8
  • TI-2023-12577 Apache Linkis gateway module token authentication bypass CVSS 3.1CRITICAL 9.1
  • TI-2022-21962 Apache Linkis (incubating): The DatasourceManager module has a serialization attack vulnerability CVSS 3.1HIGH 8.8
See all 17 →

Sources