Read the docs
TI-2023-25343 Aliases CVE-2023-46942GHSA-ggpm-9qfx-mhwg

Lack of authentication in NPM's package @evershop/evershop before version 1.0.0-rc.8…

Priority MEDIUM 40CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

Lack of authentication in NPM's package @evershop/evershop before version 1.0.0-rc.8, allows remote attackers to obtain sensitive information via improper authorization in GraphQL endpoints.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00732 54th percentileScored 2026-11-07
Fix Fixed @evershop/evershop (npm): 1.0.0-rc.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—@evershop/evershop (npm)before 1.0.0-rc.91.0.0-rc.9Patch availableGHSA-ggpm-9qfx-mhwg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • @evershop/evershop (npm) Vendor— Affected before 1.0.0-rc.9 Fixed in 1.0.0-rc.9 Patch available GHSA-ggpm-9qfx-mhwg

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:a:evershop:evershop:1.0.0:beta:*:*:*:node.js:*:*1.0.0 betaVulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:beta1:*:*:*:node.js:*:*1.0.0 beta1VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:beta2:*:*:*:node.js:*:*1.0.0 beta2VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:beta3:*:*:*:node.js:*:*1.0.0 beta3VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:beta4:*:*:*:node.js:*:*1.0.0 beta4VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:beta5:*:*:*:node.js:*:*1.0.0 beta5VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:rc1:*:*:*:node.js:*:*1.0.0 rc1VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:rc2:*:*:*:node.js:*:*1.0.0 rc2VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:rc3:*:*:*:node.js:*:*1.0.0 rc3VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:rc5:*:*:*:node.js:*:*1.0.0 rc5VulnerableEvershop
  • cpe:2.3:a:evershop:evershop:1.0.0:beta:*:*:*:node.js:*:* Versions 1.0.0 beta Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:beta1:*:*:*:node.js:*:* Versions 1.0.0 beta1 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:beta2:*:*:*:node.js:*:* Versions 1.0.0 beta2 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:beta3:*:*:*:node.js:*:* Versions 1.0.0 beta3 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:beta4:*:*:*:node.js:*:* Versions 1.0.0 beta4 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:beta5:*:*:*:node.js:*:* Versions 1.0.0 beta5 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:rc1:*:*:*:node.js:*:* Versions 1.0.0 rc1 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:rc2:*:*:*:node.js:*:* Versions 1.0.0 rc2 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:rc3:*:*:*:node.js:*:* Versions 1.0.0 rc3 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:rc5:*:*:*:node.js:*:* Versions 1.0.0 rc5 Vulnerable ·Evershop
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:evershop:evershop:1.0.0:rc6:*:*:*:node.js:*:*1.0.0 rc6VulnerableEvershop
cpe:2.3:a:evershop:evershop:1.0.0:rc7:*:*:*:node.js:*:*1.0.0 rc7VulnerableEvershop
  • cpe:2.3:a:evershop:evershop:1.0.0:rc6:*:*:*:node.js:*:* Versions 1.0.0 rc6 Vulnerable ·Evershop
  • cpe:2.3:a:evershop:evershop:1.0.0:rc7:*:*:*:node.js:*:* Versions 1.0.0 rc7 Vulnerable ·Evershop

Remediation

  • Fix · GHSA-ggpm-9qfx-mhwg @evershop/evershop (npm) Fixed in 1.0.0-rc.9 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-46942
  2. 2026-10-03 Alias added: GHSA-ggpm-9qfx-mhwg

References

  • TI-2025-40481 EverShop 2.0.1 allows a remote unauthenticated attacker to upload arbitrary files and… CVSS 3.1HIGH 7.5
  • TI-2025-11836 EverShop Order Order.resolvers.js resource injection CVSS 4.0MEDIUM 6.3
  • TI-2026-22548 EverShop Vulnerable to Arbitrary Customer Account Takeover via Exposure of Password Reset Token in API Response CVSS 3.1CRITICAL 9.8
  • TI-2023-25344 An issue was discovered in NPM's package @evershop/evershop before version 1.0.0-rc.8. CVSS 3.1CRITICAL 9.1
  • TI-2026-21008 EverShop has a Second-Order SQL Injection in URL Rewrite Processing Derived from Category URL Keys CVSS 4.0CRITICAL 9.3
  • TI-2023-25039 An issue in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain… CVSS 3.1CRITICAL 9.8
See all 14 →

Sources