Unsafe deserialization of user data in yiisoft/yii
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.29 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Yiiframework | yii | before 1.1.29 | 1.1.29 | Patch available | CNA |
| — | yiisoft/yii (Packagist) | before 1.1.29 | 1.1.29 | Patch available | GHSA-mw2w-2hj2-fg8q |
- yii VendorYiiframework Affected before 1.1.29 Fixed in 1.1.29 Patch available CNA
- yiisoft/yii (Packagist) Vendor— Affected before 1.1.29 Fixed in 1.1.29 Patch available GHSA-mw2w-2hj2-fg8q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yii:*:*:*:*:*:*:*:* | before 1.1.29 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yii:*:*:*:*:*:*:*:* Versions before 1.1.29 Vulnerable ·Yiiframework
Remediation
- Fix · CNA yii (yiisoft) Fixed in 1.1.29
- Fix · GHSA-mw2w-2hj2-fg8q yiisoft/yii (Packagist) Fixed in 1.1.29 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-47130
- 2026-10-03 Alias added: GHSA-mw2w-2hj2-fg8q
References
Patch 2
Advisory 2
More Yiiframework Yii vulnerabilities
- TI-2024-38344 Yii 2 before 2.0.52 mishandles the attaching of behavior that is defined by an __class… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-11920 Unsafe deserialization in Yii 2 CVSS 3.1CRITICAL 10.0
- TI-2024-04634 Unsafe Reflection in base Component class in yiisoft/yii2 CVSS 3.1CRITICAL 9.1
- TI-2025-02355 yiisoft Yii2 MockClass.php generate deserialization CVSS 4.0MEDIUM 5.3
- TI-2025-02354 yiisoft Yii2 SortableIterator.php getIterator deserialization CVSS 4.0MEDIUM 5.3
- TI-2023-11755 SQL injection vulnerability found in Yii Framework Yii 2 Framework before v.2.0.47 allows… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-47130 · CVE Program
- CVE-2023-47130 · NVD
- FIRST EPSS
- GHSA-mw2w-2hj2-fg8q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences