Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System…
Priority MEDIUM 40CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System prior to v1.2.0, allows remote attackers to escalate privileges via the user password update functionality.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00383 32nd percentileScored 2026-11-07
Fix Fixed swiftyedit/swiftyedit (Packagist): 1.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | swiftyedit/swiftyedit (Packagist) | before 1.2.0 | 1.2.0 | Patch available | GHSA-2492-xxqf-6h78 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- swiftyedit/swiftyedit (Packagist) Vendor— Affected before 1.2.0 Fixed in 1.2.0 Patch available GHSA-2492-xxqf-6h78
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:swiftyedit:swiftyedit:*:*:*:*:*:*:*:* | before 1.2.0 | Vulnerable | Swiftyedit |
- cpe:2.3:a:swiftyedit:swiftyedit:*:*:*:*:*:*:*:* Versions before 1.2.0 Vulnerable ·Swiftyedit
Remediation
- Fix · GHSA-2492-xxqf-6h78 swiftyedit/swiftyedit (Packagist) Fixed in 1.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-47350
- 2026-10-03 Alias added: GHSA-2492-xxqf-6h78
References
Sources
- CVE-2023-47350 · CVE Program
- CVE-2023-47350 · NVD
- FIRST EPSS
- GHSA-2492-xxqf-6h78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences