Privilege escalation through email sign-up in datahub
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
DataHub is an open-source metadata platform. In affected versions sign-up through an invite link does not properly restrict users from signing up as privileged accounts. If a user is given an email sign-up link they can potentially create an admin account given certain preconditions. If the default datahub user has been removed, then the user can sign up for an account that leverages the default policies giving admin privileges to the datahub user. All DataHub instances prior to the patch that have removed the datahub user, but not the default policies applying to that user are affected. Users are advised to update to version 0.12.1 which addresses the issue. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| datahub-project | datahub | before 0.12.1 | 0.12.1 | Patch available | CNA |
- datahub Vendordatahub-project Affected before 0.12.1 Fixed in 0.12.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:datahub_project:datahub:*:*:*:*:*:*:*:* | before 0.12.1 | Vulnerable | datahub-project |
- cpe:2.3:a:datahub_project:datahub:*:*:*:*:*:*:*:* Versions before 0.12.1 Vulnerable ·datahub-project
Remediation
- Fix · CNA datahub (datahub-project) Fixed in 0.12.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-47629
References
More datahub-project Datahub vulnerabilities
- TI-2024-14983 Default Privileges allow for high level operations for low privileged users in datahub CVSS 3.1HIGH 8.8
- TI-2023-25770 Session Expiration Misconfiguration in datahub CVSS 3.1MEDIUM 4.8
- TI-2023-10861 Deserialization of untrusted data in DataHub CVSS 3.1HIGH 8.8
- TI-2023-25780 Insecure Use of HMAC-SHA1 For Session Signing in datahub CVSS 3.1HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences