Read the docs
TI-2023-26163 Aliases CVE-2023-48300

Embed Privacy missing escaping for show_all attribute in opt-out shortcode

Priority MEDIUM 61CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The `Embed Privacy` plugin for WordPress that prevents the loading of embedded external content is vulnerable to Stored Cross-Site Scripting via `embed_privacy_opt_out` shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Version 1.8.1 contains a patch for this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00527 44th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed embed-privacy (epiphyt): 1.8.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
epiphytembed-privacybefore 1.8.11.8.1Patch availableCNA
  • embed-privacy Vendorepiphyt Affected before 1.8.1 Fixed in 1.8.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:epiph:embed_privacy:*:*:*:*:*:wordpress:*:*before 1.8.1Vulnerableepiphyt
  • cpe:2.3:a:epiph:embed_privacy:*:*:*:*:*:wordpress:*:* Versions before 1.8.1 Vulnerable ·epiphyt

Remediation

  • Fix · CNA embed-privacy (epiphyt) Fixed in 1.8.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-48300

References

  • TI-2023-28340 WordPress Embed Privacy Plugin <= 1.8.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences