Read the docs
TI-2023-26550 Aliases CVE-2023-48711GHSA-4233-7q5q-m7p6

Server-Side Request Forgery (SSRF) Vulnerability in google-translate-api-browser

Priority LOW 18CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

google-translate-api-browser is an npm package which interfaces with the google translate web api. A Server-Side Request Forgery (SSRF) Vulnerability is present in applications utilizing the `google-translate-api-browser` package and exposing the `translateOptions` to the end user. An attacker can set a malicious `tld`, causing the application to return unsafe URLs pointing towards local resources. The `translateOptions.tld` field is not properly sanitized before being placed in the Google translate URL. This can allow an attacker with control over the `translateOptions` to set the `tld` to a payload such as `@127.0.0.1`. This causes the full URL to become `https://[email protected]/...`, where `translate.google.` is the username used to connect to localhost. An attacker can send requests within internal networks and the local host. Should any HTTPS application be present on the internal network with a vulnerability exploitable via a GET call, then it would be possible to exploit this using this vulnerability. This issue has been addressed in release version 4.1.3. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

EPSS 0.00492 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed google-translate-api-browser (cjvnjde): 4.1.3google-translate-api-browser (npm): 4.1.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
cjvnjdegoogle-translate-api-browserbefore 4.1.34.1.3Patch availableCNA
—google-translate-api-browser (npm)before 4.1.04.1.0Patch availableGHSA-4233-7q5q-m7p6
  • google-translate-api-browser Vendorcjvnjde Affected before 4.1.3 Fixed in 4.1.3 Patch available CNA
  • google-translate-api-browser (npm) Vendor— Affected before 4.1.0 Fixed in 4.1.0 Patch available GHSA-4233-7q5q-m7p6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cjvnjde:google_translate_api_browser:*:*:*:*:*:*:*:*before 4.1.3Vulnerablecjvnjde
  • cpe:2.3:a:cjvnjde:google_translate_api_browser:*:*:*:*:*:*:*:* Versions before 4.1.3 Vulnerable ·cjvnjde

Remediation

  • Fix · CNA google-translate-api-browser (cjvnjde) Fixed in 4.1.3
  • Fix · GHSA-4233-7q5q-m7p6 google-translate-api-browser (npm) Fixed in 4.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-48711
  2. 2026-10-03 Alias added: GHSA-4233-7q5q-m7p6

References

Sources