Read the docs
TI-2023-26624 Aliases CVE-2023-48796GHSA-4vvc-r4p4-qgrr

Apache dolphinscheduler sensitive information disclosure

Priority LOW 35CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler. The information exposed to unauthorized actors may include sensitive data such as database credentials. Users who can't upgrade to the fixed version can also set environment variable `MANAGEMENT_ENDPOINTS_WEB_EXPOSURE_INCLUDE=health,metrics,prometheus` to workaround this, or add the following section in the `application.yaml` file ``` management:   endpoints:     web:       exposure:         include: health,metrics,prometheus ``` This issue affects Apache DolphinScheduler: from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.

Why it matters now

EPSS 0.01191 68th percentileScored 2026-11-07
Fix Fixed Apache DolphinScheduler (Apache Software Foundation): 3.0.2org.apache.dolphinscheduler:dolphinscheduler (Maven): 3.0.2+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache DolphinScheduler3.0.0 to before 3.0.23.0.2Patch availableCNA
—org.apache.dolphinscheduler:dolphinscheduler (Maven)3.0.0 to before 3.0.23.0.2Patch availableGHSA-4vvc-r4p4-qgrr
—apache-dolphinscheduler (PyPI)3.0.0 to before 3.0.23.0.2Patch availableGHSA-4vvc-r4p4-qgrr
  • Apache DolphinScheduler VendorApache Affected 3.0.0 to before 3.0.2 Fixed in 3.0.2 Patch available CNA
  • org.apache.dolphinscheduler:dolphinscheduler (Maven) Vendor— Affected 3.0.0 to before 3.0.2 Fixed in 3.0.2 Patch available GHSA-4vvc-r4p4-qgrr
  • apache-dolphinscheduler (PyPI) Vendor— Affected 3.0.0 to before 3.0.2 Fixed in 3.0.2 Patch available GHSA-4vvc-r4p4-qgrr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:dolphinscheduler:*:*:*:*:*:*:*:*3.0.0 to before 3.0.2VulnerableApache
  • cpe:2.3:a:apache:dolphinscheduler:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.2 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache DolphinScheduler (Apache Software Foundation) Fixed in 3.0.2
  • Fix · GHSA-4vvc-r4p4-qgrr org.apache.dolphinscheduler:dolphinscheduler (Maven) Fixed in 3.0.2 Advisory →
  • Fix · GHSA-4vvc-r4p4-qgrr apache-dolphinscheduler (PyPI) Fixed in 3.0.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-48796
  2. 2026-10-03 Alias added: GHSA-4vvc-r4p4-qgrr

References

  • TI-2022-22673 Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin CVSS 3.1CRITICAL 9.8
  • TI-2022-22425 Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-28858 Apache DolphinScheduler: Remote Code Execution Vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2023-26774 Remote Code Execution in Apache Dolphinscheduler CVSS 3.1CRITICAL 9.8
  • TI-2020-09634 Deserialization of untrusted data in Apache DolphinScheduler CVSS 3.1CRITICAL 9.8
  • TI-2024-28837 Incorrect default permissions in Apache DolphinScheduler CVSS 3.1CRITICAL 9.8
See all 33 →

Sources