Apache NiFi: Improper Neutralization of Input in Advanced User Interface for Jolt
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | 0.7.0 – 1.23.2 | — | No fix listed | CNA |
| — | org.apache.nifi:nifi-jolt-transform-json-ui (Maven) | before 1.24.0 | 1.24.0 | Patch available | GHSA-68pr-6fjc-wmgm |
- Apache NiFi VendorApache Affected 0.7.0 – 1.23.2 Fixed in — No fix listed CNA
- org.apache.nifi:nifi-jolt-transform-json-ui (Maven) Vendor— Affected before 1.24.0 Fixed in 1.24.0 Patch available GHSA-68pr-6fjc-wmgm
Remediation
- Fix · GHSA-68pr-6fjc-wmgm org.apache.nifi:nifi-jolt-transform-json-ui (Maven) Fixed in 1.24.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49145
- 2026-10-03 Alias added: GHSA-68pr-6fjc-wmgm
References
Advisory 4
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2023-49145 · CVE Program
- CVE-2023-49145 · NVD
- FIRST EPSS
- GHSA-68pr-6fjc-wmgm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences