Read the docs
TI-2023-26933 Aliases CVE-2023-49297GHSA-v5f6-hjmf-9mc5

Unsafe YAML deserialization in PyDrive2

Priority LOW 35CWE-502Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

PyDrive2 is a wrapper library of google-api-python-client that simplifies many common Google Drive API V2 tasks. Unsafe YAML deserilization will result in arbitrary code execution. A maliciously crafted YAML file can cause arbitrary code execution if PyDrive2 is run in the same directory as it, or if it is loaded in via `LoadSettingsFile`. This is a deserilization attack that will affect any user who initializes GoogleAuth from this package while a malicious yaml file is present in the same directory. This vulnerability does not require the file to be directly loaded through the code, only present. This issue has been addressed in commit `c57355dc` which is included in release version `1.16.2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

EPSS 0.0051 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PyDrive2 (iterative): 1.16.2PyDrive2 (PyPI): 1.16.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
iterativePyDrive2before 1.16.2; = 1.17.01.16.2Patch availableCNA
—PyDrive2 (PyPI)——No fix listedGHSA-v5f6-hjmf-9mc5
—PyDrive2 (PyPI)before 1.16.21.16.2Patch availableGHSA-v5f6-hjmf-9mc5
  • PyDrive2 Vendoriterative Affected before 1.16.2; = 1.17.0 Fixed in 1.16.2 Patch available CNA
  • PyDrive2 (PyPI) Vendor— Affected — Fixed in — No fix listed GHSA-v5f6-hjmf-9mc5
  • PyDrive2 (PyPI) Vendor— Affected before 1.16.2 Fixed in 1.16.2 Patch available GHSA-v5f6-hjmf-9mc5

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:iterative:pydrive2:*:*:*:*:*:*:*:*before 1.16.2Vulnerableiterative
cpe:2.3:a:iterative:pydrive2:1.17.0:*:*:*:*:*:*:*1.17.0Vulnerableiterative
  • cpe:2.3:a:iterative:pydrive2:*:*:*:*:*:*:*:* Versions before 1.16.2 Vulnerable ·iterative
  • cpe:2.3:a:iterative:pydrive2:1.17.0:*:*:*:*:*:*:* Versions 1.17.0 Vulnerable ·iterative

Remediation

  • Fix · CNA PyDrive2 (iterative) Fixed in 1.16.2
  • Fix · GHSA-v5f6-hjmf-9mc5 PyDrive2 (PyPI) Fixed in 1.16.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-49297
  2. 2026-10-03 Alias added: GHSA-v5f6-hjmf-9mc5

References

Sources