An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows…
Priority LOW 29CWE-601Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.
Why it matters now
EPSS 0.01079 65th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flask-Security-Too (PyPI): 5.3.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Flask-Security-Too (PyPI) | before 5.3.3 | 5.3.3 | Patch available | GHSA-672h-6x89-76m5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Flask-Security-Too (PyPI) Vendor— Affected before 5.3.3 Fixed in 5.3.3 Patch available GHSA-672h-6x89-76m5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:flask-security-too_project:flask-security-too:*:*:*:*:*:*:*:* | up to 5.3.2 | Vulnerable | Flask-security-too Project |
- cpe:2.3:a:flask-security-too_project:flask-security-too:*:*:*:*:*:*:*:* Versions up to 5.3.2 Vulnerable ·Flask-security-too Project
Remediation
- Fix · GHSA-672h-6x89-76m5 Flask-Security-Too (PyPI) Fixed in 5.3.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49438
- 2026-10-03 Alias added: GHSA-672h-6x89-76m5
References
Other 4
- https://github.com/Flask-Middleware/flask-security
- https://github.com/Flask-Middleware/flask-security/commit/8b5abc4d4db9926a3d76b34b8b03255effb5e712
- https://github.com/pypa/advisory-database/tree/main/vulns/flask-security-too/PYSEC-2023-248.yaml
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6HCYH377TPUMUHELPI36PDS2ZM4VFIXM
More Flask-security-too Project Flask-security-too vulnerabilities
- TI-2021-04344 CSRF can expose users authentication token in Flask-Security-Too CVSS 3.1HIGH 7.4
Sources
- CVE-2023-49438 · CVE Program
- CVE-2023-49438 · NVD
- FIRST EPSS
- GHSA-672h-6x89-76m5 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-49438 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences