Workflows do not require password confirmation on API level
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-284.
Summary
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. In Nextcloud Server prior to versions 26.0.9 and 27.1.4; as well as Nextcloud Enterprise Server prior to versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4; when an attacker manages to get access to an active session of another user via another way, they could delete and modify workflows by sending calls directly to the API bypassing the password confirmation shown in the UI. Nextcloud Server versions 26.0.9 and 27.1.4 and Nextcloud Enterprise Server versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4 contain a patch for this issue. No known workarounds are available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | security-advisories | 23.0.0 to before 23.0.12.13; 24.0.0 to before 24.0.12.9; 25.0.0 to before 25.0.13.4; 26.0.0 to before 26.0.9; 27.0.0 to before 27.1.4 | 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, 27.1.4 | Patch available | CNA |
- security-advisories Vendornextcloud Affected 23.0.0 to before 23.0.12.13; 24.0.0 to before 24.0.12.9; 25.0.0 to before 25.0.13.4; 26.0.0 to before 26.0.9; 27.0.0 to before 27.1.4 Fixed in 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, 27.1.4 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 23.0.0 to before 23.0.12.13; 24.0.0 to before 24.0.12.9; 25.0.0 to before 25.0.13.4 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* | 26.0.0 to before 26.0.9 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 26.0.0 to before 26.0.9 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* | 27.0.0 to before 27.1.4 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 27.0.0 to before 27.1.4 | Vulnerable | nextcloud |
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 23.0.0 to before 23.0.12.13; 24.0.0 to before 24.0.12.9; 25.0.0 to before 25.0.13.4 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* Versions 26.0.0 to before 26.0.9 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 26.0.0 to before 26.0.9 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* Versions 27.0.0 to before 27.1.4 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 27.0.0 to before 27.1.4 Vulnerable ·nextcloud
Remediation
- Fix · CNA security-advisories (nextcloud) Fixed in 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, 27.1.4
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49791
References
More Nextcloud Server vulnerabilities
- TI-2023-20855 Users can delete external storage mount points CVSS 3.1HIGH 7.7
- TI-2023-11091 Nextcloud download permissions can be changed by resharer CVSS 3.1HIGH 7.5
- TI-2023-10624 Nextcloud Server vulnerable to SSRF via filter bypass due to lax checking on IPs CVSS 3.1MEDIUM 5.3
- TI-2025-37238 Cross-site scripting in Nextcloud CVSS 3.1MEDIUM 6.4
- TI-2023-11086 nextcloud vulnerable to Uncontrolled Resource Consumption CVSS 3.1MEDIUM 6.5
- TI-2022-18738 Exception logging in Sharepoint app reveals clear-text connection details CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-49791 · CVE Program
- CVE-2023-49791 · NVD
- FIRST EPSS
- CVE-2023-49791 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences