@koa/cors has overly permissive origin policy
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-346.
Summary
@koa/cors npm provides Cross-Origin Resource Sharing (CORS) for koa, a web framework for Node.js. Prior to version 5.0.0, the middleware operates in a way that if an allowed origin is not provided, it will return an `Access-Control-Allow-Origin` header with the value of the origin from the request. This behavior completely disables one of the most crucial elements of browsers - the Same Origin Policy (SOP), this could cause a very serious security threat to the users of this middleware. If such behavior is expected, for instance, when middleware is used exclusively for prototypes and not for production applications, it should be heavily emphasized in the documentation along with an indication of the risks associated with such behavior, as many users may not be aware of it. Version 5.0.0 fixes this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| koajs | cors | before 5.0.0 | 5.0.0 | Patch available | CNA |
| — | @koa/cors (npm) | before 5.0.0 | 5.0.0 | Patch available | GHSA-qxrj-hx23-xp82 |
- cors Vendorkoajs Affected before 5.0.0 Fixed in 5.0.0 Patch available CNA
- @koa/cors (npm) Vendor— Affected before 5.0.0 Fixed in 5.0.0 Patch available GHSA-qxrj-hx23-xp82
Remediation
- Fix · CNA cors (koajs) Fixed in 5.0.0
- Fix · GHSA-qxrj-hx23-xp82 @koa/cors (npm) Fixed in 5.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49803
- 2026-10-03 Alias added: GHSA-qxrj-hx23-xp82
References
Sources
- CVE-2023-49803 · CVE Program
- CVE-2023-49803 · NVD
- FIRST EPSS
- GHSA-qxrj-hx23-xp82 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences