An issue was discovered in SchedMD Slurm 22.05.x, 23.02.x, and 23.11.x.
Priority MEDIUM 45CWE-415Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-415 and the CVSS impact.
Summary
An issue was discovered in SchedMD Slurm 22.05.x, 23.02.x, and 23.11.x. Because of a double free, attackers can cause a denial of service or possibly execute arbitrary code. The fixed versions are 22.05.11, 23.02.7, and 23.11.1.
Why it matters now
EPSS 0.01375 72nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49937
- 2026-10-03 Alias added: GHSA-crjm-8w39-c276
References
More SchedMD Slurm vulnerabilities
- TI-2019-09617 SchedMD Slurm 17.11.x, 18.08.0 through 18.08.7, and 19.05.0 allows SQL Injection. CVSS 3.1CRITICAL 9.8
- TI-2019-04508 SchedMD Slurm before 17.11.13 and 18.x before 18.08.5 mishandles 32-bit systems. CVSS 3.0CRITICAL 9.8
- TI-2022-11963 SchedMD Slurm 21.08.x through 20.11.x has Incorrect Access Control that leads to Escalation of Privileges. CVSS 3.1CRITICAL 9.8
- TI-2020-16830 Slurm before 19.05.8 and 20.x before 20.02.6 has an RPC Buffer Overflow in the PMIx MPI plugin. CVSS 3.1CRITICAL 9.8
- TI-2018-05107 SchedMD Slurm before 17.02.10 and 17.11.x before 17.11.5 allows SQL Injection attacks against SlurmDBD. CVSS 3.0CRITICAL 9.8
- TI-2022-11962 SchedMD Slurm 21.08.x through 20.11.x has Incorrect Access Control that leads to… CVSS 3.1HIGH 8.8
Sources
- CVE-2023-49937 · CVE Program
- CVE-2023-49937 · NVD
- FIRST EPSS
- GHSA-crjm-8w39-c276 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-49937 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences