Deepin Reader RCE vulnerability due to a design flaw
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Deepin Linux's default document reader `deepin-reader` software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| linuxdeepin | developer-center | before 6.0.7 | 6.0.7 | Patch available | CNA |
- developer-center Vendorlinuxdeepin Affected before 6.0.7 Fixed in 6.0.7 Patch available CNA
Remediation
- Fix · CNA developer-center (linuxdeepin) Fixed in 6.0.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-50254
References
More linuxdeepin vulnerabilities
- TI-2026-27360 Improper certificate validation in linuxdeepin dde-control-center CVSS 3.1MEDIUM 5.4
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences