Read the docs
TI-2023-27483 Aliases CVE-2023-50255

Zip Path Traversal in Deepin-Compressor

Priority MEDIUM 42CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.

Why it matters now

EPSS 0.01054 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed developer-center (linuxdeepin): 5.12.21

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
linuxdeepindeveloper-centerbefore 5.12.215.12.21Patch availableCNA
  • developer-center Vendorlinuxdeepin Affected before 5.12.21 Fixed in 5.12.21 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:deepin:deepin-compressor:*:*:*:*:*:*:*:*before 5.12.21VulnerableDeepin
  • cpe:2.3:a:deepin:deepin-compressor:*:*:*:*:*:*:*:* Versions before 5.12.21 Vulnerable ·Deepin

Remediation

  • Fix · CNA developer-center (linuxdeepin) Fixed in 5.12.21

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-50255

References

  • TI-2026-27360 Improper certificate validation in linuxdeepin dde-control-center CVSS 3.1MEDIUM 5.4

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences