Read the docs
TI-2023-27657 Aliases CVE-2023-50711GHSA-875g-mfp6-g7f9

Out-of-bounds write in rust-vmm vmm-sys-util

Priority MEDIUM 43CWE-787Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-787 and the CVSS impact.

Summary

vmm-sys-util is a collection of modules that provides helpers and utilities used by multiple rust-vmm components. Starting in version 0.5.0 and prior to version 0.12.0, an issue in the `FamStructWrapper::deserialize` implementation provided by the crate for `vmm_sys_util::fam::FamStructWrapper` can lead to out of bounds memory accesses. The deserialization does not check that the length stored in the header matches the flexible array length. Mismatch in the lengths might allow out of bounds memory access through Rust-safe methods. The issue was corrected in version 0.12.0 by inserting a check that verifies the lengths of compared flexible arrays are equal for any deserialized header and aborting deserialization otherwise. Moreover, the API was changed so that header length can only be modified through Rust-unsafe code. This ensures that users cannot trigger out-of-bounds memory access from Rust-safe code.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00652 51st percentileScored 2026-11-07
Fix Fixed vmm-sys-util (rust-vmm): 0.12.0vmm-sys-util (crates.io): 0.12.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
rust-vmmvmm-sys-util0.5.0 to before 0.12.00.12.0Patch availableCNA
—vmm-sys-util (crates.io)0.5.0 to before 0.12.00.12.0Patch availableGHSA-875g-mfp6-g7f9
  • vmm-sys-util Vendorrust-vmm Affected 0.5.0 to before 0.12.0 Fixed in 0.12.0 Patch available CNA
  • vmm-sys-util (crates.io) Vendor— Affected 0.5.0 to before 0.12.0 Fixed in 0.12.0 Patch available GHSA-875g-mfp6-g7f9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:rust-vmm:vmm-sys-util:*:*:*:*:*:rust:*:*0.5.0 to before 0.12.0Vulnerablerust-vmm
  • cpe:2.3:a:rust-vmm:vmm-sys-util:*:*:*:*:*:rust:*:* Versions 0.5.0 to before 0.12.0 Vulnerable ·rust-vmm

Remediation

  • Fix · CNA vmm-sys-util (rust-vmm) Fixed in 0.12.0
  • Fix · GHSA-875g-mfp6-g7f9 vmm-sys-util (crates.io) Fixed in 0.12.0 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-50711
  2. 2026-10-03 Alias added: GHSA-875g-mfp6-g7f9
  3. 2026-10-14 EPSS moved to the 50th–90th percentile

References

Sources