Read the docs
TI-2023-27659 Aliases CVE-2023-50713

Speckle Server API Token Privilege Escalation

Priority LOW 29CWE-1220Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
Low · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

Speckle Server provides server, frontend, 3D viewer, and other JavaScript utilities for the Speckle 3D data platform. A vulnerability in versions prior to 2.17.6 affects users who: authorized an application which requested a 'token write' scope or, using frontend-2, created a Personal Access Token (PAT) with `token write` scope. When creating a new token an agent needs to authorise the request with an existing token (the 'requesting token'). The requesting token is required to have token write scope in order to generate new tokens. However, Speckle server was not verifying that other privileges granted to the new token were not in excess of the privileges of the requesting token. A malicious actor could use a token with only token write scope to subsequently generate further tokens with additional privileges. These privileges would only grant privileges up to the existing privileges of the user. This vulnerability cannot be used to escalate a user's privileges or grant privileges on behalf of other users. This has been patched as of version 2.17.6. All operators of Speckle servers should upgrade their server to version 2.17.6 or higher. Any users who authorized an application with 'token write' scope, or created a token in frontend-2 with `token write` scope should review existing tokens and permanently revoke any they do not recognize, revoke existing tokens and create new tokens, and review usage of their account for suspicious activity. No known workarounds for this issue exist.

Why it matters now

EPSS 0.00389 33rd percentileScored 2026-11-07
Fix Fixed speckle-server (specklesystems): 2.17.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
specklesystemsspeckle-serverbefore 2.17.62.17.6Patch availableCNA
  • speckle-server Vendorspecklesystems Affected before 2.17.6 Fixed in 2.17.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:specklesystems:speckle_server:*:*:*:*:*:*:*:*before 2.17.6Vulnerablespecklesystems
  • cpe:2.3:a:specklesystems:speckle_server:*:*:*:*:*:*:*:* Versions before 2.17.6 Vulnerable ·specklesystems

Remediation

  • Fix · CNA speckle-server (specklesystems) Fixed in 2.17.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-50713

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences