Read the docs
TI-2023-27676 Aliases CVE-2023-50730GHSA-g56x-7j6w-g8r8

Grackle has StackOverflowError in GraphQL query processing

Priority LOW 34CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

Grackle is a GraphQL server written in functional Scala, built on the Typelevel stack. The GraphQL specification requires that GraphQL fragments must not form cycles, either directly or indirectly. Prior to Grackle version 0.18.0, that requirement wasn't checked, and queries with cyclic fragments would have been accepted for type checking and compilation. The attempted compilation of such fragments would result in a JVM `StackOverflowError` being thrown. Some knowledge of an applications GraphQL schema would be required to construct such a query, however no knowledge of any application-specific performance or other behavioural characteristics would be needed. Grackle uses the cats-parse library for parsing GraphQL queries. Prior to version 0.18.0, Grackle made use of the cats-parse `recursive` operator. However, `recursive` is not currently stack safe. `recursive` was used in three places in the parser: nested selection sets, nested input values (lists and objects), and nested list type declarations. Consequently, queries with deeply nested selection sets, input values or list types could be constructed which exploited this, causing a JVM `StackOverflowException` to be thrown during parsing. Because this happens very early in query processing, no specific knowledge of an applications GraphQL schema would be required to construct such a query. The possibility of small queries resulting in stack overflow is a potential denial of service vulnerability. This potentially affects all applications using Grackle which have untrusted users. Both stack overflow issues have been resolved in the v0.18.0 release of Grackle. As a workaround, users could interpose a sanitizing layer in between untrusted input and Grackle query processing.

Why it matters now

EPSS 0.00827 57th percentileScored 2026-11-07
Fix Fixed grackle (typelevel): 0.18.0org.typelevel:grackle-core_2.13 (Maven): 0.18.0+5 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
http4sgracklebefore 0.18.00.18.0Patch availableCNA
—org.typelevel:grackle-core_2.13 (Maven)before 0.18.00.18.0Patch availableGHSA-g56x-7j6w-g8r8
—org.typelevel:grackle-core_3 (Maven)before 0.18.00.18.0Patch availableGHSA-g56x-7j6w-g8r8
—org.typelevel:grackle-core_sjs1_2.13 (Maven)before 0.18.00.18.0Patch availableGHSA-g56x-7j6w-g8r8
—org.typelevel:grackle-core_sjs1_3 (Maven)before 0.18.00.18.0Patch availableGHSA-g56x-7j6w-g8r8
—org.typelevel:grackle-core_native0.4_2.13 (Maven)before 0.18.00.18.0Patch availableGHSA-g56x-7j6w-g8r8
—org.typelevel:grackle-core_native0.4_3 (Maven)before 0.18.00.18.0Patch availableGHSA-g56x-7j6w-g8r8
—edu.gemini:gsp-graphql-core_2.13 (Maven)up to 0.14.0—No fix listedGHSA-g56x-7j6w-g8r8
—edu.gemini:gsp-graphql-core_3 (Maven)up to 0.14.0—No fix listedGHSA-g56x-7j6w-g8r8
—edu.gemini:gsp-graphql-core_sjs1_2.13 (Maven)up to 0.14.0—No fix listedGHSA-g56x-7j6w-g8r8
—edu.gemini:gsp-graphql-core_sjs1_3 (Maven)up to 0.14.0—No fix listedGHSA-g56x-7j6w-g8r8
—edu.gemini:gsp-graphql-core_native0.4_2.13 (Maven)up to 0.14.0—No fix listedGHSA-g56x-7j6w-g8r8
—edu.gemini:gsp-graphql-core_native0.4_3 (Maven)up to 0.14.0—No fix listedGHSA-g56x-7j6w-g8r8
  • grackle Vendorhttp4s Affected before 0.18.0 Fixed in 0.18.0 Patch available CNA
  • org.typelevel:grackle-core_2.13 (Maven) Vendor— Affected before 0.18.0 Fixed in 0.18.0 Patch available GHSA-g56x-7j6w-g8r8
  • org.typelevel:grackle-core_3 (Maven) Vendor— Affected before 0.18.0 Fixed in 0.18.0 Patch available GHSA-g56x-7j6w-g8r8
  • org.typelevel:grackle-core_sjs1_2.13 (Maven) Vendor— Affected before 0.18.0 Fixed in 0.18.0 Patch available GHSA-g56x-7j6w-g8r8
  • org.typelevel:grackle-core_sjs1_3 (Maven) Vendor— Affected before 0.18.0 Fixed in 0.18.0 Patch available GHSA-g56x-7j6w-g8r8
  • org.typelevel:grackle-core_native0.4_2.13 (Maven) Vendor— Affected before 0.18.0 Fixed in 0.18.0 Patch available GHSA-g56x-7j6w-g8r8
  • org.typelevel:grackle-core_native0.4_3 (Maven) Vendor— Affected before 0.18.0 Fixed in 0.18.0 Patch available GHSA-g56x-7j6w-g8r8
  • edu.gemini:gsp-graphql-core_2.13 (Maven) Vendor— Affected up to 0.14.0 Fixed in — No fix listed GHSA-g56x-7j6w-g8r8
  • edu.gemini:gsp-graphql-core_3 (Maven) Vendor— Affected up to 0.14.0 Fixed in — No fix listed GHSA-g56x-7j6w-g8r8
  • edu.gemini:gsp-graphql-core_sjs1_2.13 (Maven) Vendor— Affected up to 0.14.0 Fixed in — No fix listed GHSA-g56x-7j6w-g8r8
  • edu.gemini:gsp-graphql-core_sjs1_3 (Maven) Vendor— Affected up to 0.14.0 Fixed in — No fix listed GHSA-g56x-7j6w-g8r8
  • edu.gemini:gsp-graphql-core_native0.4_2.13 (Maven) Vendor— Affected up to 0.14.0 Fixed in — No fix listed GHSA-g56x-7j6w-g8r8
  • edu.gemini:gsp-graphql-core_native0.4_3 (Maven) Vendor— Affected up to 0.14.0 Fixed in — No fix listed GHSA-g56x-7j6w-g8r8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:typelevel:grackle:*:*:*:*:*:*:*:*before 0.18.0Vulnerablehttp4s
  • cpe:2.3:a:typelevel:grackle:*:*:*:*:*:*:*:* Versions before 0.18.0 Vulnerable ·http4s

Remediation

  • Fix · CNA grackle (typelevel) Fixed in 0.18.0
  • Fix · GHSA-g56x-7j6w-g8r8 org.typelevel:grackle-core_2.13 (Maven) Fixed in 0.18.0 Advisory →
  • Fix · GHSA-g56x-7j6w-g8r8 org.typelevel:grackle-core_3 (Maven) Fixed in 0.18.0 Advisory →
  • Fix · GHSA-g56x-7j6w-g8r8 org.typelevel:grackle-core_sjs1_2.13 (Maven) Fixed in 0.18.0 Advisory →
  • Fix · GHSA-g56x-7j6w-g8r8 org.typelevel:grackle-core_sjs1_3 (Maven) Fixed in 0.18.0 Advisory →
  • Fix · GHSA-g56x-7j6w-g8r8 org.typelevel:grackle-core_native0.4_2.13 (Maven) Fixed in 0.18.0 Advisory →
  • Fix · GHSA-g56x-7j6w-g8r8 org.typelevel:grackle-core_native0.4_3 (Maven) Fixed in 0.18.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-50730
  2. 2026-10-03 Alias added: GHSA-g56x-7j6w-g8r8

References

Sources