Insufficiently protected credentials in Jenkins OpenId Connect Authentication Plugin
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins OpenId Connect Authentication Plugin 2.6 and earlier stores a password of a local user account used as an anti-lockout feature in a recoverable format, allowing attackers with access to the Jenkins controller file system to recover the plain text password of that account, likely gaining administrator access to Jenkins.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins OpenId Connect Authentication Plugin | up to 2.6 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:oic-auth (Maven) | before 4.229.vf736b | 4.229.vf736b | Patch available | GHSA-6r5w-jjr5-qvgr |
- Jenkins OpenId Connect Authentication Plugin VendorJenkins Affected up to 2.6 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:oic-auth (Maven) Vendor— Affected before 4.229.vf736b Fixed in 4.229.vf736b Patch available GHSA-6r5w-jjr5-qvgr
Remediation
- Fix · GHSA-6r5w-jjr5-qvgr org.jenkins-ci.plugins:oic-auth (Maven) Fixed in 4.229.vf736b Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins OpenId Connect Authentication Plugin — Jenkins Security Advisory 2023-12-13
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-27701 Open redirect in Jenkins OpenId Connect Authentication PluginPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2023-50770
- 2026-10-03 Alias added: GHSA-6r5w-jjr5-qvgr
References
More Jenkins Openid vulnerabilities
- TI-2023-10066 Jenkins OpenID Plugin 2.4 and earlier does not invalidate the previous session on login. CVSS 3.1CRITICAL 9.8
- TI-2023-10068 Cross-site request forgery in Jenkins OpenID Plugin CVSS 3.1HIGH 8.8
- TI-2019-15944 Missing authorization in Jenkins openid Plugin CVSS 3.1MEDIUM 6.5
- TI-2019-15943 Cross-site request forgery in Jenkins openid Plugin CVSS 3.0MEDIUM 6.5
- TI-2023-10067 Open redirect in Jenkins OpenID Plugin CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-50770 · CVE Program
- CVE-2023-50770 · NVD
- FIRST EPSS
- GHSA-6r5w-jjr5-qvgr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences