In Appwrite CLI before 3.0.0, when using the login command, the credentials of the…
Priority MEDIUM 58CWE-798Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-798.
Summary
In Appwrite CLI before 3.0.0, when using the login command, the credentials of the Appwrite user are stored in a ~/.appwrite/prefs.json file with 0644 as UNIX permissions. Any user of the local system can access those credentials.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00293 22nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed appwrite-cli (npm): 3.0.0appwrite (PyPI): 3.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | appwrite-cli (npm) | before 3.0.0 | 3.0.0 | Patch available | GHSA-g777-crp9-m27g |
| — | appwrite (PyPI) | before 3.0.0 | 3.0.0 | Patch available | GHSA-g777-crp9-m27g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- appwrite-cli (npm) Vendor— Affected before 3.0.0 Fixed in 3.0.0 Patch available GHSA-g777-crp9-m27g
- appwrite (PyPI) Vendor— Affected before 3.0.0 Fixed in 3.0.0 Patch available GHSA-g777-crp9-m27g
Remediation
- Fix · GHSA-g777-crp9-m27g appwrite-cli (npm) Fixed in 3.0.0 Advisory →
- Fix · GHSA-g777-crp9-m27g appwrite (PyPI) Fixed in 3.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-50974
- 2026-10-03 Alias added: GHSA-g777-crp9-m27g
References
Sources
- CVE-2023-50974 · CVE Program
- CVE-2023-50974 · NVD
- FIRST EPSS
- GHSA-g777-crp9-m27g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences