WordPress Booking Calendar Plugin < 9.7.4 is vulnerable to Cross Site Scripting (XSS)
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPdevelop / Oplugins WP Booking Calendar allows Stored XSS.This issue affects WP Booking Calendar: from n/a before 9.7.4.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00328 26th percentileScored 2026-11-07
Fix Fixed WP Booking Calendar (WPdevelop / Oplugins): 9.7.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WPdevelop / Oplugins | WP Booking Calendar | before 9.7.4 | 9.7.4 | Patch available | CNA |
- WP Booking Calendar VendorWPdevelop / Oplugins Affected before 9.7.4 Fixed in 9.7.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpbookingcalendar:booking_calendar:*:*:*:*:*:wordpress:*:* | before 9.7.4 | Vulnerable | Wpbookingcalendar |
- cpe:2.3:a:wpbookingcalendar:booking_calendar:*:*:*:*:*:wordpress:*:* Versions before 9.7.4 Vulnerable ·Wpbookingcalendar
Remediation
- Fix · CNA WP Booking Calendar (WPdevelop / Oplugins) Fixed in 9.7.4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-51520
- 2026-10-03 Alias added: GHSA-52rw-98p2-v2g3
References
More WPdevelop / Oplugins vulnerabilities
- TI-2023-09778 WordPress Booking Calendar plugin <= 9.4.3 - SQL Injection CVSS 3.1HIGH 7.6
Sources
- CVE-2023-51520 · CVE Program
- CVE-2023-51520 · NVD
- FIRST EPSS
- GHSA-52rw-98p2-v2g3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences