OS Command Injection for Fluid Users with JuicefsRuntime
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Fluid is an open source Kubernetes-native Distributed Dataset Orchestrator and Accelerator for data-intensive applications. An OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data. Users who're using versions < 0.9.3 with JuicefsRuntime should upgrade to v0.9.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fluid-cloudnative | fluid | before 0.9.3 | 0.9.3 | Patch available | CNA |
| — | github.com/fluid-cloudnative/fluid (Go) | before 0.9.3 | 0.9.3 | Patch available | GHSA-wx8q-4gm9-rj2g |
- fluid Vendorfluid-cloudnative Affected before 0.9.3 Fixed in 0.9.3 Patch available CNA
- github.com/fluid-cloudnative/fluid (Go) Vendor— Affected before 0.9.3 Fixed in 0.9.3 Patch available GHSA-wx8q-4gm9-rj2g
Remediation
- Fix · CNA fluid (fluid-cloudnative) Fixed in 0.9.3
- Fix · GHSA-wx8q-4gm9-rj2g github.com/fluid-cloudnative/fluid (Go) Fixed in 0.9.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-51699
- 2026-10-03 Alias added: GHSA-wx8q-4gm9-rj2g
References
Advisory 2
More backstage Fluid vulnerabilities
- TI-2023-14620 On a compromised node, the fluid-csi service account can be used to modify node specs CVSS 3.1HIGH 7.8
Sources
- CVE-2023-51699 · CVE Program
- CVE-2023-51699 · NVD
- FIRST EPSS
- GHSA-wx8q-4gm9-rj2g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences