UTF32Encoding.cpp in POCO has a Poco::UTF32Encoding integer overflow and resultant stack…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
UTF32Encoding.cpp in POCO has a Poco::UTF32Encoding integer overflow and resultant stack buffer overflow because Poco::UTF32Encoding::convert() and Poco::UTF32::queryConvert() may return a negative integer if a UTF-32 byte sequence evaluates to a value of 0x80000000 or higher. This is fixed in 1.11.8p2, 1.12.5p2, and 1.13.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pocoproject:poco:*:*:*:*:*:*:*:* | before 1.11.8; 1.12.0 to before 1.12.5 | Vulnerable | Pocoproject |
| cpe:2.3:a:pocoproject:poco:1.11.8:-:*:*:*:*:*:* | 1.11.8 | Vulnerable | Pocoproject |
| cpe:2.3:a:pocoproject:poco:1.11.8:p1:*:*:*:*:*:* | 1.11.8 p1 | Vulnerable | Pocoproject |
| cpe:2.3:a:pocoproject:poco:1.12.5:-:*:*:*:*:*:* | 1.12.5 | Vulnerable | Pocoproject |
- cpe:2.3:a:pocoproject:poco:*:*:*:*:*:*:*:* Versions before 1.11.8; 1.12.0 to before 1.12.5 Vulnerable ·Pocoproject
- cpe:2.3:a:pocoproject:poco:1.11.8:-:*:*:*:*:*:* Versions 1.11.8 Vulnerable ·Pocoproject
- cpe:2.3:a:pocoproject:poco:1.11.8:p1:*:*:*:*:*:* Versions 1.11.8 p1 Vulnerable ·Pocoproject
- cpe:2.3:a:pocoproject:poco:1.12.5:-:*:*:*:*:*:* Versions 1.12.5 Vulnerable ·Pocoproject
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-52389
- 2026-10-03 Alias added: GHSA-3g75-6vfp-4hm3
References
More Pocoproject Poco vulnerabilities
- TI-2025-05776 poco MultipartReader.cpp MultipartInputStream null pointer dereference CVSS 4.0MEDIUM 4.8
- TI-2017-14681 The ZipCommon::isValidPath() function in Zip/src/ZipCommon.cpp in POCO C++ Libraries… CVSS 3.0MEDIUM 6.5
- TI-2025-28837 poco v1.14.1-release was discovered to contain weak encryption. CVSS 3.1HIGH 7.0
Sources
- CVE-2023-52389 · CVE Program
- CVE-2023-52389 · NVD
- FIRST EPSS
- GHSA-3g75-6vfp-4hm3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences