nfc: nci: assert requested protocol is valid
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: nfc: nci: assert requested protocol is valid The protocol is used in a bit mask to determine if the protocol is supported. Assert the provided protocol is less than the maximum defined so it doesn't potentially perform a shift-out-of-bounds and provide a clearer error for undefined protocols vs unsupported ones.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.2 and later | 4.14.328, 4.19.297, 5.4.259, 5.10.199, 5.15.136, 6.1.59, 6.5.8, 6.6 | Patch available | CNA |
- Linux VendorLinux Affected 3.2 and later Fixed in 4.14.328, 4.19.297, 5.4.259, 5.10.199, 5.15.136, 6.1.59, 6.5.8, 6.6 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.2 to before 4.14.328; 4.15 to before 4.19.297; 4.20 to before 5.4.259; 5.5 to before 5.10.199; 5.11 to before 5.15.136; 5.16 to before 6.1.59; 6.2 to before 6.5.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.6:rc1:*:*:*:*:*:* | 6.6 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.6:rc2:*:*:*:*:*:* | 6.6 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.6:rc3:*:*:*:*:*:* | 6.6 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.6:rc4:*:*:*:*:*:* | 6.6 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.6:rc5:*:*:*:*:*:* | 6.6 rc5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.2 to before 4.14.328; 4.15 to before 4.19.297; 4.20 to before 5.4.259; 5.5 to before 5.10.199; 5.11 to before 5.15.136; 5.16 to before 6.1.59; 6.2 to before 6.5.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.6:rc1:*:*:*:*:*:* Versions 6.6 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.6:rc2:*:*:*:*:*:* Versions 6.6 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.6:rc3:*:*:*:*:*:* Versions 6.6 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.6:rc4:*:*:*:*:*:* Versions 6.6 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.6:rc5:*:*:*:*:*:* Versions 6.6 rc5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.328, 4.19.297, 5.4.259, 5.10.199, 5.15.136, 6.1.59, 6.5.8, 6.6
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-52507
- 2026-10-03 Alias added: GHSA-h7jr-j6p8-85m6
References
Patch 8
- https://git.kernel.org/stable/c/2c231a247a1d1628e41fa1eefd1a5307c41c5f53
- https://git.kernel.org/stable/c/a686f84101680b8442181a8846fbd3c934653729
- https://git.kernel.org/stable/c/95733ea130e35ef9ec5949a5908dde3feaba92cb
- https://git.kernel.org/stable/c/a424807d860ba816aaafc3064b46b456361c0802
- https://git.kernel.org/stable/c/25dd54b95abfdca423b65a4ee620a774777d8213
- https://git.kernel.org/stable/c/853dda54ba59ea70d5580a298b7ede4707826848
- https://git.kernel.org/stable/c/6584eba7688dcf999542778b07f63828c21521da
- https://git.kernel.org/stable/c/354a6e707e29cb0c007176ee5b8db8be7bd2dee0
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-52507 · CVE Program
- CVE-2023-52507 · NVD
- FIRST EPSS
- GHSA-h7jr-j6p8-85m6 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-52507 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences