fs/jfs: Add validity check for db_maxag and db_agpref
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-129 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: fs/jfs: Add validity check for db_maxag and db_agpref Both db_maxag and db_agpref are used as the index of the db_agfree array, but there is currently no validity check for db_maxag and db_agpref, which can lead to errors. The following is related bug reported by Syzbot: UBSAN: array-index-out-of-bounds in fs/jfs/jfs_dmap.c:639:20 index 7936 is out of range for type 'atomic_t[128]' Add checking that the values of db_maxag and db_agpref are valid indexes for the db_agfree array.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.12 and later | 4.14.331, 4.19.300, 5.4.262, 5.10.202, 5.15.140, 6.1.64, 6.5.13, 6.6.3, 6.7 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.12 and later Fixed in 4.14.331, 4.19.300, 5.4.262, 5.10.202, 5.15.140, 6.1.64, 6.5.13, 6.6.3, 6.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 4.14.331; 4.15 to before 4.19.300; 4.20 to before 5.4.262; 5.5 to before 5.10.202; 5.11 to before 5.15.140; 5.16 to before 6.1.64; 6.2 to before 6.5.13; 6.6 to before 6.6.3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.14.331; 4.15 to before 4.19.300; 4.20 to before 5.4.262; 5.5 to before 5.10.202; 5.11 to before 5.15.140; 5.16 to before 6.1.64; 6.2 to before 6.5.13; 6.6 to before 6.6.3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.331, 4.19.300, 5.4.262, 5.10.202, 5.15.140, 6.1.64, 6.5.13, 6.6.3, 6.7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
Not affected: 3 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-52804
- 2026-10-03 Alias added: GHSA-xhh8-8jq9-8vf6
References
Patch 9
- https://git.kernel.org/stable/c/a0649e2dd4a3595b5595a29d0064d047c2fae2fb
- https://git.kernel.org/stable/c/ce15b0f1a431168f07b1cc6c9f71206a2db5c809
- https://git.kernel.org/stable/c/32bd8f1cbcf8b663e29dd1f908ba3a129541a11b
- https://git.kernel.org/stable/c/c6c8863fb3f57700ab583d875adda04caaf2278a
- https://git.kernel.org/stable/c/1f74d336990f37703a8eee77153463d65b67f70e
- https://git.kernel.org/stable/c/5013f8269887642cca784adc8db9b5f0b771533f
- https://git.kernel.org/stable/c/dca403bb035a565bb98ecc1dda5d30f676feda40
- https://git.kernel.org/stable/c/2323de34a3ae61a9f9b544c18583f71cea86721f
- https://git.kernel.org/stable/c/64933ab7b04881c6c18b21ff206c12278341c72e
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-52804 · CVE Program
- CVE-2023-52804 · NVD
- FIRST EPSS
- GHSA-xhh8-8jq9-8vf6 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-52804 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences