drm/amd: Fix UBSAN array-index-out-of-bounds for SMU7
Priority LOW 34CWE-129Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-129 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: drm/amd: Fix UBSAN array-index-out-of-bounds for SMU7 For pptable structs that use flexible array sizes, use flexible arrays.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00257 17th percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.14.331, 4.19.300, 5.4.262 +6Red Hat: 4 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.5 and later | 4.14.331, 4.19.300, 5.4.262, 5.10.202, 5.15.140, 6.1.64, 6.5.13, 6.6.3, 6.7 | Patch available | CNA |
- Linux VendorLinux Affected 4.5 and later Fixed in 4.14.331, 4.19.300, 5.4.262, 5.10.202, 5.15.140, 6.1.64, 6.5.13, 6.6.3, 6.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 4.14.331; 4.15 to before 4.19.300; 4.20 to before 5.4.262; 5.5 to before 5.10.202; 5.11 to before 5.15.140; 5.16 to before 6.1.64; 6.2 to before 6.5.13; 6.6 to before 6.6.3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.14.331; 4.15 to before 4.19.300; 4.20 to before 5.4.262; 5.5 to before 5.10.202; 5.11 to before 5.15.140; 5.16 to before 6.1.64; 6.2 to before 6.5.13; 6.6 to before 6.6.3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.331, 4.19.300, 5.4.262, 5.10.202, 5.15.140, 6.1.64, 6.5.13, 6.6.3, 6.7
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2023-52818
- 2026-10-03 Alias added: GHSA-44v6-xcjw-whc3
References
Patch 9
- https://git.kernel.org/stable/c/e52e324a21341c97350d5f11de14721c1c609498
- https://git.kernel.org/stable/c/cfd8cd907fd94538561479a43aea455f5cf16928
- https://git.kernel.org/stable/c/c847379a5d00078ad6fcb1c24230e72c5609342f
- https://git.kernel.org/stable/c/8af28ae3acb736ada4ce3457662fa446cc913bb4
- https://git.kernel.org/stable/c/acdb6830de02cf2873aeaccdf2d9bca4aee50e47
- https://git.kernel.org/stable/c/fc9ac0e8e0bcb3740c6eaad3a1a50c20016d422b
- https://git.kernel.org/stable/c/6dffdddfca818c02a42b6caa1d9845995f0a1f94
- https://git.kernel.org/stable/c/92a775e7c9707aed28782bafe636bf87675f5a97
- https://git.kernel.org/stable/c/760efbca74a405dc439a013a5efaa9fadc95a8c3
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-52818 · CVE Program
- CVE-2023-52818 · NVD
- FIRST EPSS
- GHSA-44v6-xcjw-whc3 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-52818 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences