arm64: dts: qcom: sc7280: Mark PCIe controller as cache coherent
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: arm64: dts: qcom: sc7280: Mark PCIe controller as cache coherent If the controller is not marked as cache coherent, then kernel will try to ensure coherency during dma-ops and that may cause data corruption. So, mark the PCIe node as dma-coherent as the devices on PCIe bus are cache coherent.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.16 and later | 6.1.22, 6.2.9, 6.3 | Patch available | CNA |
- Linux VendorLinux Affected 5.16 and later Fixed in 6.1.22, 6.2.9, 6.3 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.16 to before 6.1.22; 6.2 to before 6.2.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.3:rc1:*:*:*:*:*:* | 6.3 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.3:rc2:*:*:*:*:*:* | 6.3 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.3:rc3:*:*:*:*:*:* | 6.3 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.16 to before 6.1.22; 6.2 to before 6.2.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.3:rc1:*:*:*:*:*:* Versions 6.3 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.3:rc2:*:*:*:*:*:* Versions 6.3 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.3:rc3:*:*:*:*:*:* Versions 6.3 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.22, 6.2.9, 6.3
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-53043
- 2026-10-03 Alias added: GHSA-qhc2-26qw-5rg9
- 2026-11-07 Affected versions changed · Red Hat
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-53043 · CVE Program
- CVE-2023-53043 · NVD
- FIRST EPSS
- GHSA-qhc2-26qw-5rg9 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-53043 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences