fs: prevent out-of-bounds array speculation when closing a file descriptor
Priority LOW 31CWE-125Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Partial Red Hat: 5 fixed, 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: fs: prevent out-of-bounds array speculation when closing a file descriptor Google-Bug-Id: 114199369
Why it matters now
EPSS 0.00207 10th percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.14.310, 4.19.278, 5.4.237 +5Red Hat: 1 advisoryRed Hat: 5 fixed, 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.12 and later | 4.14.310, 4.19.278, 5.4.237, 5.10.175, 5.15.103, 6.1.20, 6.2.7, 6.3 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.12 and later Fixed in 4.14.310, 4.19.278, 5.4.237, 5.10.175, 5.15.103, 6.1.20, 6.2.7, 6.3 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 4.14.310; 4.15 to before 4.19.278; 4.20 to before 5.4.237; 5.5 to before 5.10.175; 5.11 to before 5.15.103; 5.16 to before 6.1.20; 6.2 to before 6.2.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.3:rc1:*:*:*:*:*:* | 6.3 rc1 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.14.310; 4.15 to before 4.19.278; 4.20 to before 5.4.237; 5.5 to before 5.10.175; 5.11 to before 5.15.103; 5.16 to before 6.1.20; 6.2 to before 6.2.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.3:rc1:*:*:*:*:*:* Versions 6.3 rc1 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.310, 4.19.278, 5.4.237, 5.10.175, 5.15.103, 6.1.20, 6.2.7, 6.3
Red Hat 1 advisory
- RHSA-2025:6966 Released 2025-05-13 · Red Hat rating Moderatekernel security update
- Red Hat Enterprise Linux AppStream (v. 9) kernel-64k-debug-devel-5.14.0-570.12.1.el9_6, kernel-64k-debug-devel-matched-5.14.0-570.12.1.el9_6, kernel-64k-devel-5.14.0-570.12.1.el9_6 +12
- Red Hat Enterprise Linux BaseOS (v. 9) kernel-5.14.0-570.12.1.el9_6, kernel-64k-5.14.0-570.12.1.el9_6, kernel-64k-core-5.14.0-570.12.1.el9_6 +28
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) kernel-tools-libs-devel-5.14.0-570.12.1.el9_6, libperf-5.14.0-570.12.1.el9_6
- Red Hat Enterprise Linux Real Time (v. 9) kernel-rt-5.14.0-570.12.1.el9_6, kernel-rt-64k-5.14.0-570.12.1.el9_6, kernel-rt-64k-core-5.14.0-570.12.1.el9_6 +21
- Red Hat Enterprise Linux Real Time for NFV (v. 9) kernel-rt-5.14.0-570.12.1.el9_6, kernel-rt-core-5.14.0-570.12.1.el9_6, kernel-rt-debug-5.14.0-570.12.1.el9_6 +11
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux Real Time (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux Real Time for NFV (v. 9) | Fixed | RHSA-2025:6966 |
Not affected: 1 product
- Red Hat Enterprise Linux 10
Timeline
- 2026-10-02 Threatist record created from CVE-2023-53117
- 2026-10-03 Alias added: GHSA-45q6-6mh9-vrvp
References
Patch 8
- https://git.kernel.org/stable/c/f31cd5da636682caea424fa1c22679016cbfc16b
- https://git.kernel.org/stable/c/3d5d9501b634fd268eb56428cda92cd317752d69
- https://git.kernel.org/stable/c/6631c8da02cfad96c53b217cf647b511c7f34faf
- https://git.kernel.org/stable/c/a759905de9cd6ec9ca08ceadf0920272772ed830
- https://git.kernel.org/stable/c/f8cd8754a03a3748384ee438c572423643c9c315
- https://git.kernel.org/stable/c/cec08b7d1ebcd3138d4658b3868ce26aeb1e8e06
- https://git.kernel.org/stable/c/eea8e4e056a5ffbeb539a13854c017d5d62c756a
- https://git.kernel.org/stable/c/609d54441493c99f21c1823dfd66fa7f4c512ff4
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-53117 · CVE Program
- CVE-2023-53117 · NVD
- FIRST EPSS
- GHSA-45q6-6mh9-vrvp · GitHub Advisory Database · CC BY 4.0
- CVE-2023-53117 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences