phy: hisilicon: Fix an out of bounds check in hisi_inno_phy_probe()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: phy: hisilicon: Fix an out of bounds check in hisi_inno_phy_probe() The size of array 'priv->ports[]' is INNO_PHY_PORT_NUM. In the for loop, 'i' is used as the index for array 'priv->ports[]' with a check (i > INNO_PHY_PORT_NUM) which indicates that INNO_PHY_PORT_NUM is allowed value for 'i' in the same loop. This > comparison needs to be changed to >=, otherwise it potentially leads to an out of bounds write on the next iteration through the loop
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.17 and later | 4.19.291, 5.4.253, 5.10.190, 5.15.124, 6.1.43, 6.4.8, 6.5 | Patch available | CNA |
- Linux VendorLinux Affected 4.17 and later Fixed in 4.19.291, 5.4.253, 5.10.190, 5.15.124, 6.1.43, 6.4.8, 6.5 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.17 to before 4.19.291; 4.20 to before 5.4.253; 5.5 to before 5.10.190; 5.11 to before 5.15.124; 5.16 to before 6.1.43; 6.2 to before 6.4.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.5:rc1:*:*:*:*:*:* | 6.5 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.5:rc2:*:*:*:*:*:* | 6.5 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.5:rc3:*:*:*:*:*:* | 6.5 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.17 to before 4.19.291; 4.20 to before 5.4.253; 5.5 to before 5.10.190; 5.11 to before 5.15.124; 5.16 to before 6.1.43; 6.2 to before 6.4.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.5:rc1:*:*:*:*:*:* Versions 6.5 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.5:rc2:*:*:*:*:*:* Versions 6.5 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.5:rc3:*:*:*:*:*:* Versions 6.5 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.291, 5.4.253, 5.10.190, 5.15.124, 6.1.43, 6.4.8, 6.5
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-53238
- 2026-10-03 Alias added: GHSA-w5gr-gjhw-4xpq
References
Patch 7
- https://git.kernel.org/stable/c/2843a2e703f5cb85c9eeca11b7ee90861635a010
- https://git.kernel.org/stable/c/195e806b2afb0bad6470c9094f7e45e0cf109ee0
- https://git.kernel.org/stable/c/ad249aa3c38f329f91fba8b4b3cd087e79fb0ce8
- https://git.kernel.org/stable/c/6d8a71e4c3a2fa4960cc50996e76a42b62fab677
- https://git.kernel.org/stable/c/01cb355bb92e8fcf8306e11a4774d610c5864e39
- https://git.kernel.org/stable/c/ce69eac840db0b559994dc4290fce3d7c0d7bccd
- https://git.kernel.org/stable/c/13c088cf3657d70893d75cf116be937f1509cc0f
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-53238 · CVE Program
- CVE-2023-53238 · NVD
- FIRST EPSS
- GHSA-w5gr-gjhw-4xpq · GitHub Advisory Database · CC BY 4.0
- CVE-2023-53238 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences