power: supply: axp288_fuel_gauge: Fix external_power_changed race
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: power: supply: axp288_fuel_gauge: Fix external_power_changed race fuel_gauge_external_power_changed() dereferences info->bat, which gets sets in axp288_fuel_gauge_probe() like this: info->bat = devm_power_supply_register(dev, &fuel_gauge_desc, &psy_cfg); As soon as devm_power_supply_register() has called device_add() the external_power_changed callback can get called. So there is a window where fuel_gauge_external_power_changed() may get called while info->bat has not been set yet leading to a NULL pointer dereference. Fixing this is easy. The external_power_changed callback gets passed the power_supply which will eventually get stored in info->bat, so fuel_gauge_external_power_changed() can simply directly use the passed in psy argument which is always valid.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.18 and later | 6.1.31, 6.3.5, 6.4 | Patch available | CNA |
- Linux VendorLinux Affected 5.18 and later Fixed in 6.1.31, 6.3.5, 6.4 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.18 to before 6.1.31; 6.2 to before 6.3.5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc1:*:*:*:*:*:* | 6.4 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc2:*:*:*:*:*:* | 6.4 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc3:*:*:*:*:*:* | 6.4 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.18 to before 6.1.31; 6.2 to before 6.3.5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc1:*:*:*:*:*:* Versions 6.4 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc2:*:*:*:*:*:* Versions 6.4 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc3:*:*:*:*:*:* Versions 6.4 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.31, 6.3.5, 6.4
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-53310
- 2026-10-03 Alias added: GHSA-c4mr-qx6r-6753
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-53310 · CVE Program
- CVE-2023-53310 · NVD
- FIRST EPSS
- GHSA-c4mr-qx6r-6753 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-53310 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences